Opened 14 years ago

Closed 13 years ago

#1213 closed defect (invalid)

PVR-350: LiveTV freeze when show ends

Reported by: jasonmollman@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using svn 8862. While attempting to collect a gdb trace to help with ticket 971,mythfrontend froze at the end of a program, transitioning to another. Attached is the debug output. Attached is the trace, with -v playback, and a partial backend log with -v all,noaudio,nodatabase.

System uses a pvr-350, internal decoder, ivtv 0.4.0.

Attachments (7)

gdb.txt (19.0 KB) - added by jasonmollman@… 14 years ago.
gdb.2.txt (19.0 KB) - added by jasonmollman@… 14 years ago.
backendlog.freeze (5.4 KB) - added by jasonmollman@… 14 years ago.
gdb.3.txt (13.9 KB) - added by anonymous 14 years ago.
mythbackend.log.txt (2.3 KB) - added by jasonmollman@… 14 years ago.
8873 backend log
8873gdb.txt (13.9 KB) - added by jasonmollman@… 14 years ago.
8873 gdb trace.
livetvfreeze-frontend.log.txt (37.1 KB) - added by geoffp@… 13 years ago.
Frontend log from freeze on livetv program boundary

Download all attachments as: .zip

Change History (14)

Changed 14 years ago by jasonmollman@…

Attachment: gdb.txt added

Changed 14 years ago by jasonmollman@…

Attachment: gdb.2.txt added

Changed 14 years ago by jasonmollman@…

Attachment: backendlog.freeze added

comment:1 Changed 14 years ago by jasonmollman@…

gdb.2.txt is a duplicate of gdb.txt and can be ignored. The freeze happened at 10:00. This may just be residual of the earlier pvr-350 freeze fixes, but I thought I'd at least post it.

comment:2 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

(In [8866]) Fix a race condition (was confused about where it was in the chain during a smooth transition between shows)

Probably fixes #942, #971, #1213, and any other 'livetv breaks at end of a show' issue.

comment:3 Changed 14 years ago by anonymous

Resolution: fixed
Status: closedreopened

comment:4 Changed 14 years ago by jasonmollman@…

So, with 42 seconds left in the Super Bowl, this issue occurred again with svn 8873. At 10 pm the program was scheduled to change, and the frontend locked up. Attaching gdb trace and backend log. I wasn't able to get the frontend log.

Changed 14 years ago by anonymous

Attachment: gdb.3.txt added

Changed 14 years ago by jasonmollman@…

Attachment: mythbackend.log.txt added

8873 backend log

comment:5 Changed 14 years ago by Isaac Richards

Resolution: invalid
Status: reopenedclosed

Need a frontend log.

Changed 14 years ago by jasonmollman@…

Attachment: 8873gdb.txt added

8873 gdb trace.

comment:6 Changed 13 years ago by geoffp@…

Resolution: invalid
Status: closedreopened

I've been following this bug for some time now. This still happens for me every day at least once. I'm on a PVR150, ivtv 0.7.0, kernel 2.6.17 (gentoo), and am running 0.20 fixes, svn-11497. I will attach a frontend log, in which I see the conspicuous:

2006-10-10 19:41:26.875 NVP: prebuffering pause
2006-10-10 19:59:30.477 TV: ASK_RECORDING 2 28 0 hasrec: 0
2006-10-10 20:00:04.250 NVP: prebuffering pause
2006-10-10 20:00:05.734 NVP: Prebuffer wait timed out 10 times.
2006-10-10 20:00:07.235 NVP: Prebuffer wait timed out 10 times.
2006-10-10 20:00:08.736 NVP: Prebuffer wait timed out 10 times.
2006-10-10 20:00:10.238 NVP: Prebuffer wait timed out 10 times.

Changed 13 years ago by geoffp@…

Frontend log from freeze on livetv program boundary

comment:7 Changed 13 years ago by Isaac Richards

Resolution: invalid
Status: reopenedclosed

Frontend log *from a pvr-350 user*, as the bug title says.

Note: See TracTickets for help on using tickets.