Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12158 closed Patch - Bug Fix (Fixed)

Save volume on Music Player exit

Reported by: angela.schmid@… Owned by: paulh
Priority: minor Milestone: 0.28
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords: music player volume save
Cc: Ticket locked: no

Description

Ticket https://code.mythtv.org/trac/ticket/12063 optimizes to save the volume only at closing the TV Player. The underlying audio handler does not save each volume change.

The Music Player needs to save the volume explicitly at closing.

Patch attached.

Attachments (1)

0001-Save-volume-on-Music-Player-exit.patch (1.5 KB) - added by angela.schmid@… 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by angela.schmid@…

comment:1 Changed 5 years ago by paulh

Milestone: unknown0.28
Owner: set to paulh
Status: newassigned

comment:2 Changed 5 years ago by paulh

Resolution: Fixed
Status: assignedclosed

Fixed in [6984cda463f295]

comment:3 Changed 4 years ago by Roger Siddons <rsiddons@…>

In 426021e765ded9ac3787cdd232c4e212bb13486c/mythtv:

Revert "MythMusic: Save volume on exiting the music player"

This reverts commit 6984cda463f29587651c70452d648cb848ccb33d.

Issue was caused by 85baf6 (#12144), which is being reverted.

Refs #12158

comment:4 Changed 4 years ago by Roger Siddons

This issue arose from changes introduced by #12144. Those have been reverted in favour of an alternative solution, so this change has also been reverted for consistency.

Last edited 4 years ago by Roger Siddons (previous) (diff)
Note: See TracTickets for help on using tickets.