Opened 5 years ago

Closed 5 years ago

#12177 closed Patch - Bug Fix (Fixed)

compilation failure on 32bit systems

Reported by: john.p.harvey@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

mythframe.cpp fails to compile for 32bit target with the latest assembly code. This just addresses the cpuid bad constraints error. This is caused by the %ebx register being clobbered.

This patch was produced by referencing http://newbiz.github.io/cpp/2010/12/20/Playing-with-cpuid.html

Attachments (1)

cpuid.patch (641 bytes) - added by john.p.harvey@… 5 years ago.
patch for cpuid on 32 bit systems

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by john.p.harvey@…

Attachment: cpuid.patch added

patch for cpuid on 32 bit systems

comment:1 Changed 5 years ago by JYA

Resolution: Fixed
Status: newclosed
Note: See TracTickets for help on using tickets.