Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12181 closed Bug Report - General (Fixed)

UPnP regression after MythTV 0.24.3

Reported by: J.Pilk@… Owned by: stuartm
Priority: blocker Milestone: 0.28
Component: MythTV - UPnP Version: 0.27.1
Severity: medium Keywords: upnp
Cc: Ticket locked: no

Description

My Panasonic TV, european 2012 series E5B, plays new DVB-T recordings fine via UPnP in MythTV 0.27.1, but when they have been edited and converted to mpeg2-ps format it will only play them as 'videos', and then with poor FF/RW capability. I have not been a able to play music via UPnP at all.

I have recently re-activated an old office-spec PC with CentOS 5.10/MythTV 0.24.3 (to provide backup internet access) and find it works well with UPnP without these problems.

The 'Recordings/Videos?' problem goes away if I revert the patch at https://code.mythtv.org/trac/ticket/9446#comment:9 which applies to _all_ systems a 'correction' intended only for a specific Sony device. This fix was suggested some time ago at https://code.mythtv.org/trac/ticket/10583#comment:28

At this stage I don't have a fix for the music-via-UPnP problem.

Attachments (2)

upnpmusic_myth0p24p3.txt (5.2 KB) - added by J.Pilk@… 5 years ago.
upnpmusic_myth0p27p1.txt (2.5 KB) - added by J.Pilk@… 5 years ago.

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by J.Pilk@…

Attachment: upnpmusic_myth0p24p3.txt added

Changed 5 years ago by J.Pilk@…

Attachment: upnpmusic_myth0p27p1.txt added

comment:1 Changed 5 years ago by J.Pilk@…

The title should have referred to a 'regression.' I've added logs from the two systems.

comment:2 Changed 5 years ago by stuartm

Component: MythTV - GeneralMythTV - UPnP
Milestone: unknown0.28
Owner: set to stuartm
Status: newaccepted

comment:3 Changed 5 years ago by stuartm

Summary: UPnP reversion after MythTV 0.24.3UPnP regression after MythTV 0.24.3

comment:4 Changed 5 years ago by stuartm

The proper fix here is to start storing information on the recording container and codecs so we can send the correct information with the upnp request. This is also required for full HLS/DASH support so there's good reason to make this a priority.

Sending 'bad' data as we do now is not DLNA compliant, but neither is sending nothing. Since we don't know the user agents of the Sony devices we can't just implement a workaround that works for them but not other devices, I doubt it was only Sony devices which were affected anyway. Much as I would like to provide a temporary solution for 0.27 while we work on a full solution for 0.28, I just can't think of one.

comment:5 Changed 5 years ago by stuartm

Priority: minorblocker

comment:6 Changed 5 years ago by J.Pilk@…

An update on the original report: in 0.27.3 'Music' now works if I 'Import' the content file instead of just dropping it into the 'Music' directory and scanning for changes. I think I'm using the simplest possible way of setting up the metadata requirements and haven't examined more complex options. .mp2 files aren't recognised unless renamed as .mp3

Re #9446: It might well be effective for other devices, but
sProtocol += ";DLNA.ORG_PN=MPEG_TS_SD_NA_ISO"; appears to be for North America, with _EU_, _JP_, _KO_ (etc?) also plausible. As noted, my TV works best with it reverted.

<friendlyName>VIERA E5 Series</friendlyName>

<manufacturer>Panasonic</manufacturer> <modelName>Panasonic VIErA</modelName>

http://www.upnp-database.info/listDevices.jsp appears to be still getting some updates.

comment:7 Changed 5 years ago by stuartm

Status: acceptedinfoneeded

Is the situation any better, or worse, with the latest master?

comment:8 Changed 5 years ago by John Pilkington <J.Pilk@…>

I don't recall any major problems with upnp on master since this post on 12 Oct

http://www.gossamer-threads.com/lists/mythtv/dev/577643#577643

I'm now running v0.28-pre-2422-g8e6678a, but patched to play DVB-T SD recordings after cutting and conversion to mpeg2-ps. As patched it won't play the raw recording. DVB-T2 h264 is fine.

That patch/hack was posted here:

http://www.gossamer-threads.com/lists/mythtv/dev/576408#576408

Videos in all these formats play, but duration and current position are both shown as zero, making in-play navigation difficult.

Playback of 'music' BBC podcasts has the same defect and has seemed unreliable, failing with no log info and not at a specific place after around 40 minutes. I haven't used it a lot.

These comments are only about playing content. The selection menus work but I haven't tested other metadata or artwork.

Thanks for your work on this.

comment:9 Changed 5 years ago by stuartm

Resolution: Fixed
Status: infoneededclosed

The remaining issues seem related to the bad implementation of UPnP in Panasonic TVs.

The patch you are using shouldn't be necessary if the recordings were transcoded by mythtranscode as there is currently a hack in master to treat these as MPEG-PS. If it was transcoded external to MythTV then we've no way of knowing the container/codec without reinspecting the file, which for speed reasons is not something we want to do each time you browse the files. I hope to add a periodic check and update of file attributes at a later date.

The durations are correctly supplied for recordings, in two different forms (res duration attribute, and item metadata). We also correctly signal that the files (video and audio) are seekable.

comment:10 Changed 5 years ago by John Pilkington <J.Pilk@…>

Unpatched master (from ubuntu ppa) plays raw SD recordings via upnp on the above tv; it plays SD recordings processed by mythDVBcut after applying

'update recorded set transcoded = 1 where basename = "cccc_yyyymmddhhmmssxx.mpg" ;'

  • so I have added this to my working script and hope to discontinue use of the patch at comment 8.

I haven't found a 'mythutil' equivalent of the mysql procedure.

comment:11 Changed 5 years ago by John Pilkington <J.Pilk@…>

I ought to have added: setting the 'transcoded' flag triggers the switch here:

/mythtv-master/mythtv/programs/mythbackend/upnpcdstv.cpp

line 1216

Note: See TracTickets for help on using tickets.