Opened 5 years ago

Closed 5 years ago

#12197 closed Bug Report - General (Fixed)

uPnP not working

Reported by: jam@… Owned by: stuartm
Priority: minor Milestone: 0.27.3
Component: MythTV - UPnP Version: 0.27-fixes
Severity: medium Keywords: uPnP
Cc: Ticket locked: no

Description

uPnP not working On version fixes/0.27 [v0.27-229-g9f353cc-dirty] no upnp client response On version fixes/0.27 [v0.27.2-1-g572c4e3-dirty] the headings are all valid but all content is listed as size 0 and does not play. I once upon a time did have [v0.27-229-g9f353cc-dirty] working but upgraded DB from way back when. With a new DB this does not work. Posts to user mailing lists show others eg John Pilkington with same issue and no one saying it just works.

Change History (14)

comment:1 Changed 5 years ago by JYA

Milestone: unknown0.27.3
Resolution: Fixed
Status: newclosed

fixed in 0.27.3

comment:2 Changed 5 years ago by mtbdrew@…

Resolution: Fixed
Status: closednew

I just did fresh install of Ubuntu 14.04 with Mythtv 0.27 and am seeing the same issue. Content is visible in remote dlna client but details list as 0 --:-- and video fail to play. Remote mythfrontend plays content correct. Have upgraded to mythtv 0.28 and see same issue.

comment:3 Changed 5 years ago by JYA

And what version are you using.

See the tickets how to before re-opening bugs with "me too"

comment:4 Changed 5 years ago by mtbdrew@…

Originally on v0.27 that came with release of Mythbuntu 14.04 daily updates installed as of this past Monday when I moved to v0.28, now on v0.28-pre-1976-g477c3f2

comment:5 Changed 5 years ago by JYA

And your upnp client is?

comment:6 Changed 5 years ago by stuartm

It just works for me, with a number of different UPnP players (all software).

There are known issues with some players which require strict DLNA compliance, that's something we're working on fixing for 0.28.

comment:7 Changed 5 years ago by stuartm

Status: newinfoneeded_new

Also what type of media are you trying to play, video, music or recordings? When you say size do you mean the size reported by the UPnP client or the size in the xml response from mythbackend?

comment:8 Changed 5 years ago by JYA

Resolution: Fixed
Status: infoneeded_newclosed

it does work for me too.

If you're having issues, and it's unlikely related to this bug (seeing that it was fixed), open a new ticket, and this time read the ticket howto and provide the relevant information.

in particular the exact myth version used, and the upnp client

comment:9 Changed 5 years ago by mtbdrew@…

The How to states do a search before creating a new ticket to see if there is an existing issue which is exactly what I did!

To make the assumption about a fix is pretty foolish, especially when you haven't even looked at a single log! glad my customers don't have to deal with the likes of you!

I searched the forums found several cases of the issue still being seen on latest updates. Then search this place before creating a new ticket and found an existing one that exactly described what I am seeing. "On version fixes/0.27 [v0.27.2-1-g572c4e3-dirty] the headings are all valid but all content is listed as size 0 and does not play." I stated I was now using Mythtv 0.28 with all daily updates installed. As well as having started with 0.27 and all daily updates installed.

Maybe this is not the exact same thing but it might be how about giving more details in the bug thread besides fixed, so the end use can test if this is the same issue? To assume I know what details you want besides the version of MythTv? is down right stupid. I didn't write the code and don't know exactly what all this application uses. I have tried searching the Mythtv documents but they are extremely vague basically stating it works. I've posted questions on both Ubuntu and Mythtv forums and gotten zero responses. I figured the next step was to come here and try to get some help. Guess not, seems you are more interested in following goofy little procedure and closing cases than fixing bugs and making a quality product.

comment:10 Changed 5 years ago by stuartm

Component: MythTV - GeneralMythTV - UPnP
Owner: set to dblain
Resolution: Fixed
Status: closednew

We want to help you, but you still haven't answered the questions we asked. We can't work in the dark.

This ticket was opened shortly after a botched commit was made which caused upnp clients to use the wrong port for the http server. We were alerted to the issue and it was fixed fairly quickly in [979ea9b7f]. The presumption was that this ticket related to that issue, which was confirmed fixed and remains fixed. Possibly it's unrelated, but there was little information to work with and none of the developers are able to reproduce the issue.

We do ask that people look for existing _open_ tickets before creating new ones. Re-opening old tickets unless you are the original reporter is discouraged, since only the original reporter can say for sure that the exact issue they reported was fixed. One issue per ticket, otherwise chaos ensues.

We haven't been able to look at logs because you haven't provided any. We don't leave tickets hanging around in the expectation that the reporter will eventually get around to providing the necessary information because it rarely happens that way.

  • We need the logs from the backend with -v upnp.
  • We also need to know which upnp client you are using, this is important.
  • We need to know exactly which types of media are't working.
  • We need to know what 'size' you are referring to.

comment:11 Changed 5 years ago by stuartm

Owner: changed from dblain to stuartm
Status: newaccepted

comment:12 Changed 5 years ago by stuartm

Status: acceptedinfoneeded

comment:13 Changed 5 years ago by JYA

With vlc on iphone, the size does appear as 0. But it does play fine.

Still, the new issue has nothing to do with the original reported problem. It only existed in 0.27.2 for a short time and Ubuntu ships with 0.27.1

comment:14 Changed 5 years ago by stuartm

Resolution: Fixed
Status: infoneededclosed
Note: See TracTickets for help on using tickets.