Opened 5 years ago

Closed 18 months ago

#12199 closed Bug Report - General (Won't Fix)

Invalid file requested when scrolling quickly through recordings list

Reported by: stuartm Owned by:
Priority: major Milestone: 0.27.7
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Can reproduce this one fairly reliably, seems to help if the frontend hasn't cached the preview images. The segfault is always preceeded with lines suggesting that the backend was asked to open a completely invalid url, not yet sure where this is coming from. It obviously shouldn't be segfaulting though.

2014-07-05 10:09:26.031192 E  FileRingBuf(//home/gbee/tmp//home/gbee/tmp): OpenFile(): Could not open.
2014-07-05 10:09:26.035760 E  MainServer: Can't open //home/gbee/tmp//home/gbee/tmp
2014-07-05 10:09:26.036288 W  MainServer: Unknown socket closing MythSocket(0x299a480)

Attachments (1)

backtrace.txt (46.8 KB) - added by stuartm 5 years ago.
Full Backtrace

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by stuartm

Attachment: backtrace.txt added

Full Backtrace

comment:1 Changed 5 years ago by stuartm

Priority: blockermajor
Severity: highmedium
Summary: Backend segfault when paging/scrolling quickly through recordings listInvalid file requested when scrolling quickly through recordings list
Type: Bug Report - CrashBug Report - General

The seems to be the one already fixed in [98bec5c8]. Leaving just the question of how the backend comes to be requesting such an obviously bad file path.

comment:2 Changed 5 years ago by JYA

Can you reproduce that one in 0.27 or master only?

A bit confused with the milestone

comment:3 Changed 5 years ago by stuartm

Master only, I've not tried 0.27. The milestone reflects the earliest version at fix will go into, assuming it proves to be an issue in 0.27 as well. 'Version' reflects the latest version in which the bug was found.

comment:4 Changed 4 years ago by Stuart Auchterlonie

Milestone: 0.27.40.27.6

comment:5 Changed 3 years ago by Karl Egly

Milestone: 0.27.60.27.7

Reschedule all tickets planned for, but not solved in time for, 0.27.6 to 0.27.7.

comment:6 Changed 18 months ago by Stuart Auchterlonie

Resolution: Won't Fix
Status: newclosed

Closing any remaining open tickets for 0.27

If the issue still persists, feel free to reopen and align to a current release (v29 or master)

Note: See TracTickets for help on using tickets.