Opened 5 years ago

Closed 5 years ago

#12210 closed Bug Report - General (Works for me)

0.27/fixes 20140714 mythtranscode mpeg lossless transcode fails

Reported by: tobias.powalowski@… Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Mythtranscode Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

German sky recording fails on lossless transcode. Audio channels are again misidentfied as mp3 and 0 channels. The result is again audio free conversion. Sample file provided below. -O FFMPEGTS=1 identifies the channels correct.

Attachments (1)

debug.txt (3.7 KB) - added by tobias.powalowski@… 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by tobias.powalowski@…

Attachment: debug.txt added

comment:1 Changed 5 years ago by tobias.powalowski@…

https://dev.archlinux.org/~tpowa/broken-audio.mpg Sample file provided. Used commands: mythtranscode -i broken-audio.mpg --video --mpeg2 -o foo.mpg

comment:2 Changed 5 years ago by stuartm

The first thing that occurs to me here is that mythtranscode should abort if it believes it has found no audio stream. Video without audio would be rare, and non-existent for the broadcast TV that our users will be transcoding.

Transcoding the file without audio and deleting the original in the process is unacceptable, better to refuse to transcode instead.

comment:3 Changed 5 years ago by tobias.powalowski@…

The original recording is not deleted, it keeps it as it is. Mythtv just errors out here. If you analyse the files mythtranscode produces you see no audio on them.

comment:4 Changed 5 years ago by JYA

Can't reproduce in master.

comment:5 Changed 5 years ago by JYA

Resolution: Works for me
Status: newclosed

works for me in fixes/0.27 too

Note: See TracTickets for help on using tickets.