Opened 6 years ago

Closed 3 years ago

Last modified 2 years ago

#12274 closed Bug Report - General (fixed)

frontend stores snapshots and never deletes them

Reported by: mythtv@… Owned by: Peter Bennett
Priority: minor Milestone: 30.0
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I am really starting to get hacked off with MythTV. There appears to be little or no regression testing and little or no actual testing.

The next piece of crap I have found is that mythfrontend stores snapshots of tv in png format in ~/.mythtv/cache/themecache/MythCenter-wide.2560.1440 & ~/.mythtv/cache/remotecache AND NEVER DELETES THEM. This results in disk space being needlessly used up.

These should NEVER be created as the frontend has no notion of when the backend deletes the recordings.

To all developers, start getting a grip and act professional. The number of screw ups are no longer acceptable.

I suggest mythtv is promoted to v1 and like the Linux kernel, no patches should break any part of it.

Change History (8)

comment:1 Changed 5 years ago by Stuart Auchterlonie

Milestone: 0.27.40.27.6

comment:2 Changed 4 years ago by Karl Egly

Milestone: 0.27.6unknown

Sadly it appears as if we are lacking the developer resources to look into this issue in time for the milestone. Resetting the milestone back to the default.

comment:3 Changed 3 years ago by David Hampton <mythtv@…>

I committed fixes at https://github.com/MythTV/mythtv/pull/148 to rearrange the placement of cached files and to implement aging.

comment:4 Changed 3 years ago by Stuart Auchterlonie

Milestone: unknown30.0

comment:5 Changed 3 years ago by Peter Bennett

This will be very helpful for Raspberry Pi users, since the "disk space" on an SD card is very limited. I have experienced an SD card run out of space for this reason, the .mythtv directory can grow to gigabytes in size.

comment:6 Changed 3 years ago by Peter Bennett

Owner: set to Peter Bennett
Status: newassigned

comment:7 Changed 3 years ago by David Hampton <mythtv@…>

Resolution: fixed
Status: assignedclosed

In 2d1607f278c8cb18314e60a0ebc9c80b77950ff1/mythtv:

Fixes #12274 - Provide cleanup for cache in .mythtv directory

Rearrange the placement of cached files and implement aging.

Merge remote-tracking branch 'linuxdude42/devel/dh/cacheing'

Signed-off-by: Peter Bennett <pbennett@…>

comment:8 Changed 2 years ago by Peter Bennett

Owner: changed from Peter Bennett to Peter Bennett
Note: See TracTickets for help on using tickets.