Opened 14 years ago

Closed 14 years ago

#1236 closed defect (fixed)

when viewing recorded programs with PVR-350, screen is initially black

Reported by: mythtv.cvs@… Owned by: Isaac Richards
Priority: blocker Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

SVN8896. When I view any recorded programs, the screen starts out black. If I ff/rew/do anything, the screen then appears normal, and I can watch the recorded program.

From what I can tell, the program is playing perfectly behind the black screen. I hear the sound of the recording, and so on.

Change History (5)

comment:1 Changed 14 years ago by danielk

With what revision did this start?

comment:2 Changed 14 years ago by mythtv.cvs@…

Within the last 24 hours.

If you want me to test a few key revisions, let me know and I can... as long as the info on how to check out specific SVN versions is on the wiki somewhere..

comment:3 Changed 14 years ago by anonymous

Ok, I see how.

I'm going to roll back to 8888, then try a few points forward from that.

comment:4 Changed 14 years ago by danielk

Milestone: 0.19
Priority: minorblocker
Version: head

I just e-mailed L8R a few possible fixes, this shouldn't be hard to fix; I just don't have the setup so I need him to test...

comment:5 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [8903]) Fixes #1236.

Sets alpha to local initially, and disables the kAlpha_Clear optimization in ProcessFrame?().

The first fix prevents the background from showing through initially. The second fix prevents it from showing through when a PiP is on screen.

Note: See TracTickets for help on using tickets.