Opened 14 years ago

Closed 14 years ago

#1239 closed defect (worksforme)

instant record and scheduled recording don't mix well

Reported by: mythtv.cvs@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I was watching a LiveTV show at 12:10am, and decided to record it using the record button. On the same channel, I had a recording previously scheduled for 12:30am.

Before the end of my show, the familiar "what do you want to do" conflict menu popped up, indicating I had three choices. The abort the upcoming recording (third down) item was pre-selected, whereas generally the record upcoming event and watch (top) item is usually selected by default.

Anyhow, the reasons are obvious for the default select on abort. I was in a conflict and I had two slightly overlapping recordings scheduled on the same video source (note: I have other tuners, but I realise Myth isn't yet able to shift recordings to other tuners on demand like this yet).

I moved from the "cancel upcoming recording" item (third) to "let it record and watch" item (top). I left it there. Eventually the next show came on (and being on the same channel, I did not realise that my request was not being honoured).

I'm not sure what should happen here precisely, but in this particular case the "let it record and watch" item was not possible. Perhaps it should be "cancel this recording and let the scheduled recording happen".

In any case, the mythbackend logs show it canceling the scheduled recording, in favour of the livetv recording, even though I told it to record the scheduled recording...

Change History (1)

comment:1 Changed 14 years ago by bjm

Resolution: worksforme
Status: newclosed

There is so much wrong in this narrative other than "I'm not sure". However, the case inaccurately describe does work correctly. Post stories and questions to the mailing lists. This is not a message board for chit chat. Use Trac only for tested patches, backtraces or specific steps to reproducing a specific misbehavior of the software.

Note: See TracTickets for help on using tickets.