Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12403 closed Bug Report - Crash (fixed)

Plugin MythMusic crashes on a specific MP3 file

Reported by: Wayne McDougall <waynemcdougall@…> Owned by: paulh
Priority: minor Milestone: 0.28
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Playing one of my MP3 files causes a segfault in mythfrontend. Nothing obviously wrong I can spot with MP3 file which plays in iTunes. Pressing I on the file in mythMusic brings up all the metadata correctly.

I can make the mp3 file available by email.

Attachments (3)

version.txt (718 bytes) - added by Wayne McDougall <waynemcdougall@…> 5 years ago.
gdb.txt (70.4 KB) - added by Wayne McDougall <waynemcdougall@…> 5 years ago.
Backtrace
mythfrontend.extract.log (395.8 KB) - added by Wayne McDougall <waynemcdougall@…> 5 years ago.
Relevant extract from log file (debug, all)

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by Wayne McDougall <waynemcdougall@…>

Attachment: version.txt added

Changed 5 years ago by Wayne McDougall <waynemcdougall@…>

Attachment: gdb.txt added

Backtrace

Changed 5 years ago by Wayne McDougall <waynemcdougall@…>

Attachment: mythfrontend.extract.log added

Relevant extract from log file (debug, all)

comment:1 Changed 5 years ago by paulh

It's crashing in ffmpeg but don't see anything obvious in the code to cause this.

Please email me the mp3 and I'll try to reproduce it.

comment:2 Changed 5 years ago by paulh

The problem seems to be the file has two streams the mp3 audio stream and a mjpeg video stream that contains the coverart.

For some reason this is causing the probe to fail in RemoteAVFormatContext::Open(). Might just be the size of the probe buffer isn't big enough for this file if the coverart stream is the first one in the file.

comment:3 Changed 5 years ago by Paul Harrison <pharrison@…>

Resolution: fixed
Status: newclosed

In 4dfbb918174710d97170ba8f6ff5aac74863fe12/mythtv:

MythMusic: fix segfault if av_probe_input_format() fails to guess the format

Also add some additional debugging to flag a failed probe. Fixes #12403.

comment:4 Changed 5 years ago by Paul Harrison <pharrison@…>

In 06d94ce5f4d75d6791f9994c46e24d8855119c0e/mythtv:

MythMusic: double the size of the probe buffer to 64k

Some mp3 files with their coverart in a mjpeg stream were failing to be probed
with only a 32k buffer. Refs #12403.

comment:5 Changed 5 years ago by paulh

Milestone: unknown0.28
Note: See TracTickets for help on using tickets.