Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#12419 closed Bug Report - Crash (fixed)

[MHEG] Qt5 causes crash on playback QXcbConnection: XCB error: 3 (BadWindow)

Reported by: jksjdevelop@… Owned by: Roger Siddons <rsiddons@…>
Priority: minor Milestone: 0.28
Component: Qt5 issues Version: Master Head
Severity: medium Keywords: qt5
Cc: Ticket locked: no

Description

Maater head runs absolutely reliably on my system using source compiled with qt4 or todays mythbuntu binary, which I am presuming is still compiled with qt4. When compiled with qt5 the frontend crashes after showing a few seconds of H264 FreeviewHD video. Any file will do.

2015-03-20 17:35:51.020754 I  Setup Interrupt handler
2015-03-20 17:35:51.020771 I  Setup Terminated handler
2015-03-20 17:35:51.020776 I  Setup Segmentation fault handler
2015-03-20 17:35:51.020780 I  Setup Aborted handler
2015-03-20 17:35:51.020784 I  Setup Bus error handler
2015-03-20 17:35:51.020788 I  Setup Floating point exception handler
2015-03-20 17:35:51.020791 I  Setup Illegal instruction handler
2015-03-20 17:35:51.020796 I  Setup Real-time signal 0 handler
2015-03-20 17:35:51.020801 I  Setup User defined signal 1 handler
2015-03-20 17:35:51.020804 I  Setup User defined signal 2 handler
2015-03-20 17:35:51.020870 C  mythfrontend version: master [v0.28-pre-2774-g0b0a228] www.mythtv.org
2015-03-20 17:35:51.020876 C  Qt version: compile: 5.2.1, runtime: 5.2.1
2015-03-20 17:35:51.020877 N  Enabled verbose msgs:  general
2015-03-20 17:35:51.020886 N  Setting Log Level to LOG_INFO
2015-03-20 17:35:51.031391 N  Using runtime prefix = /usr/local
2015-03-20 17:35:51.031408 N  Using configuration directory = /home/tv/.mythtv
2015-03-20 17:35:51.031527 I  Added logging to the console
2015-03-20 17:35:51.031530 I  Assumed character encoding: en_GB.UTF-8
2015-03-20 17:35:51.041913 N  Empty LocalHostName.
2015-03-20 17:35:51.041927 I  Using localhost value of tv
2015-03-20 17:35:51.053234 N  Setting QT default locale to en_GB
2015-03-20 17:35:51.053245 I  Current locale en_GB
2015-03-20 17:35:51.053278 N  Reading locale defaults from /usr/local/share/mythtv//locales/en_gb.xml
2015-03-20 17:35:51.055627 I  Starting process manager
2015-03-20 17:35:51.055865 I  Starting process signal handler
2015-03-20 17:35:51.055906 I  Starting IO manager (read)
2015-03-20 17:35:51.057418 I  Starting IO manager (write)
2015-03-20 17:35:51.157138 I  ScreenSaverX11Private: DPMS is active.
2015-03-20 17:35:51.174958 N  Desktop video mode: 1920x1080 60.000 Hz
2015-03-20 17:35:51.219502 I  Listening on TCP 127.0.0.1:6547
2015-03-20 17:35:51.219533 I  Listening on TCP 192.168.1.108:6547
2015-03-20 17:35:51.219588 I  Listening on TCP [::1]:6547
2015-03-20 17:35:51.219614 I  Listening on TCP [fe80::468a:5bff:fe86:40b7%eth4]:6547
2015-03-20 17:35:52.405868 I  Loading en_gb translation for module mythfrontend
2015-03-20 17:35:52.422594 N  Desktop video mode: 1920x1080 60.000 Hz
2015-03-20 17:35:52.424769 I  Using 1920x1080 60.000 Hz
2015-03-20 17:35:52.424779 I  SwitchToGUI: Switched to 1920x1080 60.000 Hz
2015-03-20 17:35:52.503614 I  LIRC: Successfully initialized '/dev/lircd' using '/home/tv/.lircrc' config
2015-03-20 17:35:52.503670 I  No joystick configuration found, not enabling joystick control
2015-03-20 17:35:52.552056 E  CECAdapter: Failed to find any CEC devices.
2015-03-20 17:35:52.552199 I  CECAdapter: Closing down CEC.
2015-03-20 17:35:52.552211 I  UDPListener: Enabling
2015-03-20 17:35:52.552650 I  Binding to UDP 127.0.0.1:6948
2015-03-20 17:35:52.552671 I  Binding to UDP 192.168.1.108:6948
2015-03-20 17:35:52.552702 I  Binding to UDP [::1]:6948
2015-03-20 17:35:52.552726 I  Binding to UDP [fe80::468a:5bff:fe86:40b7%eth4]:6948
2015-03-20 17:35:52.552749 I  Binding to UDP 192.168.1.255:6948
2015-03-20 17:35:52.569997 I  Using Frameless Window
2015-03-20 17:35:52.570004 I  Using Full Screen Window
2015-03-20 17:35:52.618011 I  UI Screen Resolution: 1920 x 1080
2015-03-20 17:35:52.762605 I  OpenGL: Sync to VBlank is enabled (good!)
2015-03-20 17:35:53.492245 I  Trying the OpenGL 2.0 render
2015-03-20 17:35:53.503244 I  OpenGL2: GLSL supported
2015-03-20 17:35:53.503294 I  OpenGL: OpenGL vendor  : NVIDIA Corporation
2015-03-20 17:35:53.503297 I  OpenGL: OpenGL renderer: GeForce 210/PCIe/SSE2
2015-03-20 17:35:53.503299 I  OpenGL: OpenGL version : 3.3.0 NVIDIA 331.113
2015-03-20 17:35:53.503306 I  OpenGL: Max texture size: 8192 x 8192
2015-03-20 17:35:53.503309 I  OpenGL: Max texture units: 4
2015-03-20 17:35:53.503311 I  OpenGL: Direct rendering: Yes
2015-03-20 17:35:53.503313 I  OpenGL: PixelBufferObject support available
2015-03-20 17:35:53.648300 I  OpenGL: Initialised MythRenderOpenGL
2015-03-20 17:35:54.182533 I  MythCoreContext::ConnectCommandSocket(): Connecting to backend server: 192.168.1.108:6543 (try 1 of 1)
2015-03-20 17:35:54.183289 I  MythCoreContext::CheckProtoVersion(): Using protocol version 85
2015-03-20 17:35:58.252428 I  MythUIWebBrowser: Loading css from - file:///usr/local/share/mythtv/themes/default/htmls/mythbrowser.css
2015-03-20 17:35:58.268141 I  MythUIWebBrowser: enabling plugins
2015-03-20 17:35:58.328245 I  Current MythTV Schema Version (DBSchemaVer): 1339
2015-03-20 17:35:58.771571 N  Registering Internal as a media playback plugin.
2015-03-20 17:35:58.810755 W  No plugins directory /usr/local/lib/mythtv/plugins
2015-03-20 17:35:58.811491 I  Listening on TCP 127.0.0.1:6546
2015-03-20 17:35:58.811512 I  Listening on TCP 192.168.1.108:6546
2015-03-20 17:35:58.811543 I  Listening on TCP [::1]:6546
2015-03-20 17:35:58.811567 I  Listening on TCP [fe80::468a:5bff:fe86:40b7%eth4]:6546
2015-03-20 17:35:58.846159 N  Found mainmenu.xml for theme 'Steppes'
2015-03-20 17:35:58.847892 I  Registering HouseKeeperTask 'HardwareProfiler'.
2015-03-20 17:35:58.848284 I  Starting HouseKeeper.
2015-03-20 17:35:59.104998 I  Bonjour: Service registration complete: name 'Mythfrontend on tv' type '_mythfrontend._tcp.' domain: 'local.'
2015-03-20 17:36:03.893163 I  TV::TV(): Creating TV object
2015-03-20 17:36:03.898897 N  Suspending idle timer
2015-03-20 17:36:03.901462 I  TV::Init(): Created TvPlayWindow.
2015-03-20 17:36:03.912426 I  TV::HandleStateChange(): Attempting to change from None to WatchingPreRecorded
2015-03-20 17:36:04.624058 N  AudioPlayer: Enabling Audio
2015-03-20 17:36:04.821954 I  AFD: codec MP2 has 2 channels
2015-03-20 17:36:04.822030 I  AFD: Opened codec 0x44f0ae0, id(MP2) type(Audio)
2015-03-20 17:36:04.822227 I  AFD: Opened codec 0x4628e80, id(DVB_SUBTITLE) type(Subtitle)
2015-03-20 17:36:04.822234 I  AFD: codec AC3 has 2 channels
2015-03-20 17:36:04.822388 I  AFD: Opened codec 0x46299c0, id(AC3) type(Audio)
2015-03-20 17:36:05.358365 I  VDPAU: Version 1
2015-03-20 17:36:05.358373 I  VDPAU: Information NVIDIA VDPAU Driver Shared Library  331.113  Mon Dec  1 20:28:22 PST 2014
2015-03-20 17:36:05.374225 I  AFD: Opened codec 0x44f0640, id(H264) type(Video)
ALSA lib conf.c:4578:(parse_args) Unknown parameter AES0
ALSA lib conf.c:4711:(snd_config_expand) Parse arguments error: No such file or directory
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM hw:CARD=NVidia,DEV=7,AES0=6,AES1=0x82,AES2=0x00,AES3=0x01
2015-03-20 17:36:05.397068 I  AOBase: Opening audio device 'hw:CARD=NVidia,DEV=7' ch 2(2) sr 48000 sf signed 16 bit reenc 0
2015-03-20 17:36:05.605137 E  ALSA: no playback control PCM found on mixer device default
2015-03-20 17:36:05.605143 E  ALSA: Unable to open audio mixer. Volume control disabled
2015-03-20 17:36:05.634486 I  Clearing OpenGL painter cache.
2015-03-20 17:36:05.650719 I  Changing to 1920x1080 50.000 Hz
2015-03-20 17:36:06.240989 I  VDPAU: Created 2 output surfaces.
2015-03-20 17:36:06.241010 I  VDPAU: Created VDPAU render device 1920x1080
2015-03-20 17:36:06.268110 N  Player(0): Forcing decode extra audio option on (Video method requires it).
2015-03-20 17:36:06.308850 I  VidOutVDPAU: Added 2 new buffers. New buffer size 16 (4 decode and 12 process)
[freemheg] WARN Launch not found //a
[freemheg] WARN Launch not found //startup
2015-03-20 17:36:06.963932 I  Player(0): Video timing method: USleep with busy wait
2015-03-20 17:36:06.964150 I  TV::StartPlayer(): Created player.
2015-03-20 17:36:06.964187 I  TV::HandleStateChange(): Changing from None to WatchingPreRecorded
2015-03-20 17:36:06.985262 I  TV::HandleStateChange(): Main UI disabled.
2015-03-20 17:36:06.985301 I  TV::StartTV(): Entering main playback loop.
2015-03-20 17:36:07.006255 I  ScreenSaverX11Private: DPMS Deactivated 1
2015-03-20 17:36:07.041802 I  VDPAU: Added 2 output surfaces (total 4, max 4)
QXcbConnection: XCB error: 3 (BadWindow), sequence: 679, resource id: 0, major code: 15 (QueryTree), minor code: 0
Trying to construct an instance of an invalid type, type id: 67129088
Trying to construct an instance of an invalid type, type id: 594044160
Trying to construct an instance of an invalid type, type id: 779380078
Trying to construct an instance of an invalid type, type id: 620756992
Trying to construct an instance of an invalid type, type id: 795896929
Trying to construct an instance of an invalid type, type id: 71652449
Trying to construct an instance of an invalid type, type id: 577124397
Trying to construct an instance of an invalid type, type id: 644113509
terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc
2015-03-20 17:36:11.971337 C  Received Aborted: Code -6, PID 13149, UID 1000, Value 0x00000000
2015-03-20 17:36:12.071487 I  TV::StartTV(): Exiting main playback loop.
2015-03-20 17:36:12.096686 W  MythPainter: 36 images not yet de-allocated.
2015-03-20 17:36:12.096790 I  VDPAU Painter: Clearing VDPAU painter cache.
2015-03-20 17:36:12.153001 I  Using 1920x1080 50.000 Hz
2015-03-20 17:36:12.153017 I  SwitchToGUI: Switched to 1920x1080 50.000 Hz
Aborted

Change History (7)

comment:1 Changed 5 years ago by jksjdevelop@…

This issue is caused by the MHEG processing associated with Freeview and Freesat, please modify the title accordingly. Clearing the interactive tv setting in setup provides a work round. Changing the renderer from VDPAU to software showed:-

2015-03-20 19:43:32.479128 I  TV::HandleStateChange(): Changing from None to WatchingPreRecorded
[freemheg] WARN Launch not found //a
[freemheg] WARN Launch not found //startup
2015-03-20 19:43:32.509108 I  TV::HandleStateChange(): Main UI disabled.
2015-03-20 19:43:32.509159 I  TV::StartTV(): Entering main playback loop.
2015-03-20 19:43:32.635556 I  VideoOutput: Created YV12 OSD.
Trying to construct an instance of an invalid type, type id: 67129088

comment:2 Changed 5 years ago by Stuart Auchterlonie

Component: MythTV - GeneralQt5 issues
Milestone: unknown0.28
Summary: Qt5 causes crash on playback QXcbConnection: XCB error: 3 (BadWindow)[MHEG] Qt5 causes crash on playback QXcbConnection: XCB error: 3 (BadWindow)
Type: Bug Report - GeneralBug Report - Crash

comment:3 Changed 5 years ago by jksjdevelop@…

Noting that as the issue in #12423 has similar symptoms I tried clearing the frontend cache in .mythtv/cache/mythfrontend-tv but the problem still occurs.

comment:4 Changed 4 years ago by john.p.harvey@…

I just looked at this and the cache that needs clearing is in ~/.cache/mythfrontend Set up in NAMthread::run in libmythtv/netstream.cpp

After removing that cache the files i have play cleanly. It seems odd that the cache is not under .mythtv

comment:5 Changed 4 years ago by jksjdevelop@…

I can confirm that this issue is no longer present after a clean qt5 install - please close.

comment:6 Changed 4 years ago by Roger Siddons <rsiddons@…>

Owner: set to Roger Siddons <rsiddons@…>
Resolution: fixed
Status: newclosed

In a6fec7d759ff2b7b51b9eb7bb3bb1d33484141bb/mythtv:

Relocate another cache directory

Move netstream cache from ~.cache/mythfrontend to ~.mythtv/cache/netstream-

Fixes #12419

comment:7 Changed 4 years ago by Roger Siddons <rsiddons@…>

In a6fec7d759ff2b7b51b9eb7bb3bb1d33484141bb/mythtv:

Relocate another cache directory

Move netstream cache from ~.cache/mythfrontend to ~.mythtv/cache/netstream-

Fixes #12419

Note: See TracTickets for help on using tickets.