Opened 5 years ago

Closed 5 years ago

#12441 closed Bug Report - General (Fixed)

mythwelcome seems to be receiving IR events while mythfrontend is active

Reported by: sdt@… Owned by: peper03
Priority: minor Milestone: unknown
Component: MythTV - Mythwelcome & Mythshutdown Version: 0.27.4
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This started happening in the last two weeks or so.

Symptoms are:

  • Pressing stop while watching something will drop me back to mythwelcome, but the frontend still seems to be running. Pressing OK to start the frontend immediately starts the video back up, but it's playing underneath the mythwelcome cross-hatch background.
  • Other times I will exit the frontend back out to mythwelcome, but mythwelcome is gone and I'm back at the desktop.
  • Sometimes mythshutdown gets randomly locked (not hung, but like mythshutdown --lock)

I'm not sure about the first one, but the second two both correspond to items in the mythwelcome pop-up menu.

To test my IR events theory, I tried to activate mythwelcome's 'Shutdown Now' menu item from the frontend. It's the third item on the list, so to activate it from mythwelome: MENU, DOWN, DOWN, OK.

It took a couple of tries, but I was able to shutdown by hitting that series of remote buttons from within the frontend.

I suspect these commits may be related, but this is mere speculation.

https://github.com/MythTV/mythtv/commit/65ada0cff0b1a5c8c06846303cf2dad51980d1aa https://github.com/MythTV/mythtv/commit/5d5eb048e9356ed43bcbb87294c0c1030ddc8c8e

Combined FE/BE with latest 0.27 packages from mythbuntu repo. Version: 2:0.27.4+fixes.20150418.7860e91-0ubuntu0mythbuntu4

Change History (5)

comment:1 Changed 5 years ago by paulh

Owner: set to peper03
Status: newassigned

comment:2 Changed 5 years ago by peper03

Your version (78606e91) does not contain the second commit you mentioned. Your build is from the 18th April but that second commit (which fixes the problem) is from the 20th.

The current latest 0.27 package from the mythbuntu repo is 2:0.27.4+fixes.20150426.bcdaa88.

Please upgrade and the problem should be fixed.

comment:3 Changed 5 years ago by sdt@…

I see that the trusty package is at 2:0.27.4+fixes.20150426.bcdaa88, but precise is still on 2:0.27.4+fixes.20150418.7860e91

Is precise still supported?

http://ppa.launchpad.net/mythbuntu/0.27/ubuntu/dists/precise/main/binary-i386/Packages http://ppa.launchpad.net/mythbuntu/0.27/ubuntu/dists/trusty/main/binary-i386/Packages

comment:4 Changed 5 years ago by sdt@…

Which is of course a question for the mythbuntu folks. I'll go ask them.

Thanks!

comment:5 Changed 5 years ago by peper03

Resolution: Fixed
Status: assignedclosed

Closing this ticket as fixed. If the problem persists with a build including [5d5eb04] feel free to report it.

Note: See TracTickets for help on using tickets.