Opened 4 years ago

Closed 3 years ago

#12465 closed Bug Report - General (Fixed)

Services returning non matching icons for a specific search

Reported by: Stuart Auchterlonie Owned by: Stuart Auchterlonie
Priority: minor Milestone: 29.0
Component: Services - Icon Downloads Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Queried for ITV 4. Neither the result from the specific search, nor the result set based on the CSV query for "ITV 4 +1" (the actual channel required) returned anything like the correct set of results.

Yet a previous automatic query for ITV +1 managed to return a result set including ITV 4+1 but not anything related to ITV +1

Attaching results of tcpdump the conversation with services.mythtv.org

Attachments (1)

services-mythtv-bad-channel-icon-search-results.txt (2.1 KB) - added by Stuart Auchterlonie 4 years ago.
conversation capture via tcpdump

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by Stuart Auchterlonie

conversation capture via tcpdump

comment:1 Changed 4 years ago by Karl Egly

Component: MythTV - GeneralServices - Icon Downloads

comment:2 Changed 4 years ago by Stuart Auchterlonie

Milestone: 0.280.29
Status: newaccepted

comment:3 Changed 4 years ago by Stuart Auchterlonie

Milestone: 0.2929.0

Milestone renamed

comment:4 Changed 4 years ago by Stuart Auchterlonie

Current services rewrite is handling this much better....

$ curl 'localhost:3000/channel-icon/search?s=ITV%204&csv="ITV4+1","","ITV4+1","12294","0","0","9018","15920"'
"3220","ITV 4","http://lyngsat-logo.com/logo/tv/ii/itv4.png"
"25958","ITV 4 +1","http://lyngsat-logo.com/logo/tv/ii/itv4_plus1.png"
"26799","ITV 4 HD","http://lyngsat-logo.com/logo/tv/ii/itv4_hd.png"
"30212","ITV 4 HD","http://lyngsat-logo.com/hires/ii/itv4_hd.png"

That is a useful result set....

comment:5 Changed 3 years ago by Stuart Auchterlonie

Resolution: Fixed
Status: acceptedclosed

So this was caused by the relevant icons being blocked, they have been unblocked and the expected results are being returned.

Note: See TracTickets for help on using tickets.