Opened 4 years ago

Closed 4 years ago

#12508 closed Bug Report - General (Won't Fix)

Some channels in Hong Kong not covered

Reported by: Walter Cheuk <wwycheuk@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Channel Scanner Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In Hong Kong, the channel used by TV broadcast is from 471.25MHz (channel 21) to 802MHz (channel 62)[1]. It seems that they are not all covered by the 'channel frequency table'. I tried 'europe-west' and 'try-all' and can't get all the channels, whereas I can watch them on ordinary TV.

[1]: http://www.ofca.gov.hk/filemanager/ofca/common/Industry/broadcasting/television/free_tv/tvbnet.pdf

Change History (8)

comment:1 Changed 4 years ago by Walter Cheuk <wwycheuk@…>

BTW, what's the frequency range used by 'europe-west'?

comment:2 Changed 4 years ago by sphery

All of the frequencies used in Hong Kong are covered by FREQ_UHF, which is included as part of europe-west as well as some other analog frequency tables (see https://github.com/MythTV/mythtv/blob/master/mythtv/libs/libmythtv/frequencies.cpp#L848 and line #899). Hong Kong seems to use the PAL-I broadcast system as well as a subset of frequencies that are used in the UK, so europe-west is an appropriate choice of frequency table. (That said, europe-west has several channel blocks that aren't used in Hong Kong, while italy (pal_italy) and southafrica (pal_bcast_za) have only 10 extra channels and newzealand (pal_newzealand) has only 11 extra, so those choices may be useful for limiting the time spent scanning unused frequencies--southafrica probably being the most "intuitive" choice since it also uses PAL-I.)

Similarly, it looks like the digital channels used by DTMB would be covered by the UK digital frequency table (see https://github.com/MythTV/mythtv/blob/master/mythtv/libs/libmythtv/frequencytables.cpp#L327 ), though I'm not sure whether the other values specified for dvbt_ofdm_gb0 would apply for DTMB.

I can't decide whether adding an analog frequency table specifically for Hong Kong that includes only FREQ_UHF for analog (with a comment including the link to the tvbnet.pdf document you linked, above) would be worthwhile for making configuration more intuitive for users in Hong Kong, at least through the analog shut off in 2020. The europe-west frequency table is already set as a default in the MythLocale? defaults file for Hong Kong ( https://github.com/MythTV/mythtv/blob/master/mythtv/locales/zh_hk.xml ), but the name isn't likely to make users think it's correct unless they know that Hong Kong is using a subset of the frequencies used by the UK.

A digital table specifically for Hong Kong may make sense depending on whether FrequencyTable? properties need to be modified versus the UK one (in which case, it definitely makes sense) or not (in which case it may not make sense, even though they're currently using only channels in the range from 22 (482MHz) through 62 (802MHz)--only 7 less than UK's 21 (474MHz) through 68 (850MHz)--but they may be allowed to/eventually use more channels--I'm guessing the same UHF block could potentially be used). If so, it's down to whether it makes sense to use a more intuitive name.

So, MythTV's not picking up all your channels is likely due to other factors, such as card/driver issues, signal issues, or similar problems unrelated to the frequency table.

comment:3 Changed 4 years ago by Walter Cheuk <wwycheuk@…>

The problem is not with the hardware because I can tune to all the channels under Windows (using TotalMedia?). I am asking elsewhere to see if it is driver issue.

comment:4 Changed 4 years ago by Walter Cheuk <wwycheuk@…>

There is a "Scan configuration" and I chose "UK". What's its use?

comment:5 Changed 4 years ago by Walter Cheuk <wwycheuk@…>

Under 'channels scan', I can see it scan from channel 21 to 62, but the results for channel 60-62 are not shown. Is this normal?

comment:6 Changed 4 years ago by Walter Cheuk <wwycheuk@…>

Please add new options for Hong Kong, as the current names are not intuitive for average users. Also the "country" under "scan configuration" could not be set using defaults file.

I will wait for a newer version of kernel to see if it is a driver issue.

comment:7 Changed 4 years ago by Walter Cheuk <wwycheuk@…>

The frequency problem is a driver issue. And I have submitted a new bug report #12551 for the entry name problem. It's OK to close this bug. Thank you.

comment:8 Changed 4 years ago by Nicolas Riendeau

Resolution: Won't Fix
Status: newclosed
Note: See TracTickets for help on using tickets.