Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#12518 closed Bug Report - General (fixed)

mythfrontend DoHandleUndelete - loops in Master

Reported by: jksjdevelop@… Owned by: Richard Hulme <peper03@…>
Priority: minor Milestone: 29.0
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

v0.28-pre-3078-g7126654 Attempting to restore a deleted program using mythfrontend causes the back end to loop. The restore operation is however successful and the program can be viewed having restarted the backend. Strangely the same operation works perfectly from mythweb.

ProcessRequest recordinginfo.cpp:635 (ApplyRecordRecGroupChange) ApplyRecordRecGroupChange: Deleted to Default (1)
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: I Scheduler scheduler.cpp:2268 (HandleReschedule) Reschedule requested for CHECK -3 3522 0 DoHandleUndelete | Mock the Week |  | Dara O Briain and the team return for another series of the topical comedy featuring guests James Acaster, Rob Beckett, Ellie Taylor and Josh Widdicombe. | fp.bbc.co.uk/1rkhzk
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: N ProcessRequest recordinginfo.cpp:635 (ApplyRecordRecGroupChange) ApplyRecordRecGroupChange: Default to Default (1)
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: I Scheduler scheduler.cpp:2381 (HandleReschedule) Scheduled 93 items in 0.1 = 0.00 match + 0.00 check + 0.06 place
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: I Scheduler scheduler.cpp:2268 (HandleReschedule) Reschedule requested for CHECK -3 3522 0 DoHandleUndelete | Mock the Week |  | Dara O Briain and the team return for another series of the topical comedy featuring guests James Acaster, Rob Beckett, Ellie Taylor and Josh Widdicombe. | fp.bbc.co.uk/1rkhzk
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: N ProcessRequest recordinginfo.cpp:635 (ApplyRecordRecGroupChange) ApplyRecordRecGroupChange: Default to Default (1)
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: I Scheduler scheduler.cpp:2268 (HandleReschedule) Reschedule requested for CHECK -3 3522 0 DoHandleUndelete | Mock the Week |  | Dara O Briain and the team return for another series of the topical comedy featuring guests James Acaster, Rob Beckett, Ellie Taylor and Josh Widdicombe. | fp.bbc.co.uk/1rkhzk
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: N ProcessRequest recordinginfo.cpp:635 (ApplyRecordRecGroupChange) ApplyRecordRecGroupChange: Default to Default (1)
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: I Scheduler scheduler.cpp:2268 (HandleReschedule) Reschedule requested for CHECK -3 3522 0 DoHandleUndelete | Mock the Week |  | Dara O Briain and the team return for another series of the topical comedy featuring guests James Acaster, Rob Beckett, Ellie Taylor and Josh Widdicombe. | fp.bbc.co.uk/1rkhzk
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: N ProcessRequest recordinginfo.cpp:635 (ApplyRecordRecGroupChange) ApplyRecordRecGroupChange: Default to Default (1)
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: I Scheduler scheduler.cpp:2268 (HandleReschedule) Reschedule requested for CHECK -3 3522 0 DoHandleUndelete | Mock the Week |  | Dara O Briain and the team return for another series of the topical comedy featuring guests James Acaster, Rob Beckett, Ellie Taylor and Josh Widdicombe. | fp.bbc.co.uk/1rkhzk
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: N ProcessRequest recordinginfo.cpp:635 (ApplyRecordRecGroupChange) ApplyRecordRecGroupChange: Default to Default (1)
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: I Scheduler scheduler.cpp:2268 (HandleReschedule) Reschedule requested for CHECK -3 3522 0 DoHandleUndelete | Mock the Week |  | Dara O Briain and the team return for another series of the topical comedy featuring guests James Acaster, Rob Beckett, Ellie Taylor and Josh Widdicombe. | fp.bbc.co.uk/1rkhzk
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: N ProcessRequest recordinginfo.cpp:635 (ApplyRecordRecGroupChange) ApplyRecordRecGroupChange: Default to Default (1)
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: I Scheduler scheduler.cpp:2381 (HandleReschedule) Scheduled 93 items in 0.1 = 0.01 match + 0.00 check + 0.04 place
Oct  2 19:01:11 tv mythbackend: mythbackend[2429]: I Scheduler scheduler.cpp:2268 (HandleReschedule) Reschedule requested for CHECK -3 3522 0 DoHandleUndelete | Mock the Week |  | Dara O Briain and the team return for another series of the topical comedy featuring guests James Acaster, Rob Beckett, Ellie Taylor and Josh Widdicombe. | fp.bbc.co.uk/1rkhzk

Change History (7)

comment:1 Changed 4 years ago by matthias.strubel@…

Can be confirmed with

mythbackend version: fixes/0.28 [3543e74] www.mythtv.org ; on Archlinux package version ; mythtv 1:0.28-3

2016-07-18 20:48:50.026912 N [12988/17506] ProcessRequest? recordinginfo.cpp:635 (ApplyRecordRecGroupChange?) - ApplyRecordRecGroupChange?: Default to Default (1) 2016-07-18 20:48:50.028276 I [12988/15245] Scheduler scheduler.cpp:2268 (HandleReschedule?) - Reschedule requested for CHECK -3 2188 0 DoHandleUndelete? | An deiner Seite | ..

AFAIK recording was not undeleted manually.

Tried to remove the recording rule from recording rule list via mythweb, did not help. Delete processing for the named recording "An der Seite" was not processed by backend.

Corresponding logfile

http://mastr.deusexmachina.org/~matze/mythTV/loop/mythbackend.20160718182050.1314.log

Database-Dump: http://mastr.deusexmachina.org/~matze/mythTV/loop/mythconverg.dump.gz

let me know, if you need anything else.

best regards Matthias

comment:2 in reply to:  1 Changed 4 years ago by matthias.strubel@…

Replying to matthias.strubel@…:

AFAIK recording was not undeleted manually.

Not true, just talked with my wife: The recording was deleted and undeleted (within a few seconds) via mythfronend.

I had 24hours a loop until the filesystem was full of logfiles (mysql bin-logs).

I resolved the problem with: removing the recording rule (did not help in first place) and then removed the corresponding entry in the table recordedprogram .. ( I hope that does not cause further issues)

comment:3 Changed 4 years ago by Richard Hulme <peper03@…>

Owner: set to Richard Hulme <peper03@…>
Resolution: fixed
Status: newclosed

In 86bd8a84e47a3ca183437d053a28764be26e5376/mythtv:

Fix getting stuck in an infinite loop when undeleting a recording.

Fixes #12518

comment:4 Changed 4 years ago by Stuart Auchterlonie

Milestone: unknown29.0

Richard,

Does this need a cherry-pick back to 0.28 or is that unaffected?

Regards Stuart

comment:5 Changed 4 years ago by Peter Bennett

FYI I also experienced this problem a few weeks ago in 0.28. Killing the frontend resolved it, but only after I had tried a lot of other things that did not work. I vote to cherry-pick into 0.28.

comment:6 Changed 4 years ago by peper03

Yes, it should be in 0.28 too. I don't actually think there's any risk to cherry-picking it immediately since the effects are fairly clear.

comment:7 Changed 4 years ago by Richard Hulme <peper03@…>

In efbedfb142ede80ee9d1e6e7ba6bce61e9998d31/mythtv:

Fix getting stuck in an infinite loop when undeleting a recording.

Fixes #12518
(cherry picked from commit 86bd8a84e47a3ca183437d053a28764be26e5376)

Note: See TracTickets for help on using tickets.