Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12570 closed Bug Report - Crash (fixed)

FE segfaults on VC1 BluRay rip playback attempt

Reported by: warpme@… Owned by: JYA
Priority: minor Milestone: 0.28
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords: VC-1 playback crash
Cc: Ticket locked: no

Description

Attempt to play VC-1 BluRay? MKV rip gives FE segfault. Issue probably is regression after last ffmpeg re-sync as MKV file in question was playing ok in past. FE trace attached. First 100MB of troubling MKV file can be downloaded from http://warped.homenet.org/ticket.mkv

Attachments (1)

back-trace.log (37.4 KB) - added by warpme@… 4 years ago.
FE backtrace

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by warpme@…

Attachment: back-trace.log added

FE backtrace

comment:1 Changed 4 years ago by blm-ubunet@…

The file plays fine in:-

  • ffplay (recent ffmpeg)
  • mythffplay (git master)
  • mythtv without VDPAU decode/rendering.
  • mpv using VDPAU

comment:2 Changed 4 years ago by warpme@…

@blm-ubunet Thx for pointer. Main Q is: is it plays ok with mythtv using VDAPU for You? For me it looks like many VC1 files are not playable with current master :-(

comment:3 Changed 4 years ago by blm-ubunet@…

@warpme Your file & one VC1 encoded BD (Bladerunner) both crash mythfrontend when using VDPAU. Both play okay with mpv (using VDPAU). It appears that VC1 decode using VDPAU is broken.

comment:4 Changed 4 years ago by JYA

Status: newaccepted

can reproduce it here...

comment:5 Changed 4 years ago by Jean-Yves Avenard <jyavenard@…>

Resolution: fixed
Status: acceptedclosed

In 9b9b9ab45805d09d571ad7386754cfd5acb1d8bf/mythtv:

Fix VDPAU VC1 decoding (and maybe others).

For some reasons, for VC1, get_format is called during the scanning of streams. Before we're ready to do anything.

Fixes #12570

comment:6 Changed 4 years ago by paulh

Milestone: unknown0.28
Note: See TracTickets for help on using tickets.