Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12583 closed Bug Report - Hang/Deadlock (Upstream Bug)

Backend setup failed & locked my computer

Reported by: garry.leach@… Owned by: JYA
Priority: major Milestone: unknown
Component: MythTV - Mythtv-setup Version: 0.27.3
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I use Mythbuntu 14.04, on 3 PCs, dedicated to recording TV. This setup is usually OK.

One of my hard drives, for storing recorded TV, failed, so I planned to remove it from storage devices.

When I clicked on Backend setup, the standard light & dark blue/wavy screen opened, but there was no menu. Instead a bug report popped-up .

However, neither the mouse nor keyboard would work.

So, I could not send the bug report, nor could I exit this app, nor shut down the computer.

I had to use the power button to shut down.

I did not think to try ctl/alt/F1 at that time.

I rebooted & tried again, with the same result in myth backend setup. However, this time, I used ctl/alt/del to access a terminal & was able to shut it down from there.

This was the master backend. I have a separate frontend, plus one slave backend.

When I rebooted again, I confirmed that Myth itself worked, so I just left it alone. Recordings seemed to work OK, so I guess that Myth knew that one of the HDD was missing & used the other HDD. I also directed most of the recordings to the tuners on the slave backend, so as to use its storage HDD.

Change History (3)

comment:1 Changed 3 years ago by Garry Leach <garry.leach@…>

I noticed on a scrap of paper that I had written the bug info:

"/usr/bin/mythtv-setup.real crashed with SIGSEGV in nouveau_bufctx_reset()".

Also, not all of my recordings were OK. 2 of them appeared to record (with their file sizes showing on Watch Recordings), but the file can not be found.

comment:2 Changed 3 years ago by stuartm

Resolution: Upstream Bug
Status: newclosed

It crashed in the nouveau library not in MythTV, and since the whole machine locked up the problem can only have been in the kernel or a driver itself. A complete machine lockup is only caused when the problem occurred in the kernel.

comment:3 Changed 3 years ago by Garry Leach <garry.leach@…>

Thanks for your comment - it gave me a bit of a clue.

I am mostly an end user, so not all that familiar with these things, but I remembered from somewhere that "nouveau" related to graphics, particularly in the context of "driver".

I changed my graphics card & the problem went away.

Garry.

Note: See TracTickets for help on using tickets.