Opened 14 years ago

Closed 14 years ago

#1259 closed defect (fixed)

Myth Frontend crashes during playback

Reported by: chris [at] glovercc.plus.com Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

SVN Revision: 8922 (but has been happening since about December) GCC 3.4.5 Qt 3.3.4-r8 (Gentoo ebuild) Nvidia drivers 8178 kernel 2.6.15 2xHauppauge Nova-T DVB (Conexant based Model 909) on Freeview in UK

I have a feeling this problem is unique to me, but here's the info.

Whilst watching a programme the frontend crashes during playback. This only seems to happen during recorded programmes. Live TV seems to behave much better.

Anybody got any ideas what might be causing the crash, I think I have a rogue library somewhere. I've rebuilt Qt, and removed my entire myth install and rebuilt.

I've attached a gdb backtrace and a frontend log (-v all,nodatabase)

Any help gratefully received.

Thanks

Chris

Attachments (1)

gdb.txt (50.6 KB) - added by chris [at] glovercc.plus.com 14 years ago.
gdb backtrace

Download all attachments as: .zip

Change History (3)

Changed 14 years ago by chris [at] glovercc.plus.com

Attachment: gdb.txt added

gdb backtrace

comment:1 Changed 14 years ago by chris [at] glovercc.plus.com

Having trouble uploading the frontend playback log (it's 1.3Mb), so it's here

http://www.lastseen.co.uk/~chris/mythlog.zip

More info:-

I do have OpenGLVsync on, but I get the same effect with it turned off. Machine is a 3.2GHz Pentium 4(Prescott) 1Gb RAM, Kernel Software RAID SATA disks, Nvidia 6200 graphics.

HTH

Chris

comment:2 Changed 14 years ago by chris [at] glovercc.plus.com

Resolution: fixed
Status: newclosed

I think I've found my problem... weirdness with linking of libGL.

I'll close this ticket for now, but I'll keep running the frontend under GDB for a while, so if I have the problem again, I'll resubmit it.

Thanks

Chris

Note: See TracTickets for help on using tickets.