Opened 2 years ago

Closed 4 months ago

#12674 closed Bug Report - General (Won't Fix)

Live TV Guide cannot change channel

Reported by: jheizer@… Owned by:
Priority: minor Milestone: 0.28.2
Component: MythTV - General Version: 0.28.0
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When using the livetv guide to channels that cross over to another tuner the channel change does not happen. I am able to directly enter a channel number to execute the channel change.

Confirmaed by stuarta on IRC

  • stuarta fires up frontend

<stuarta> nope <stuarta> hitting enter, all i get is a message (on the log) "Clearing OpenGL painter cache"

The lines with CoreContext? mythpainter_ogl.cpp:62 (ClearCache?) Clearing OpenGL painter cache. Were the pressing of select in the guide.

I was using VDPAU, stuarta, VAAPI.

Attachments (2)

mythfrontend.log (32.0 KB) - added by Jon Heizer <jheizer@…> 2 years ago.
version.txt (1022 bytes) - added by Jon Heizer <jheizer@…> 2 years ago.

Download all attachments as: .zip

Change History (15)

Changed 2 years ago by Jon Heizer <jheizer@…>

Attachment: mythfrontend.log added

Changed 2 years ago by Jon Heizer <jheizer@…>

Attachment: version.txt added

comment:1 in reply to:  description Changed 2 years ago by xtragb@…

Same problem here when attempting to change channel going from HDPVR source to HDHomerun source. I am using VDPAU as well.

Replying to jheizer@…:

When using the livetv guide to channels that cross over to another tuner the channel change does not happen. I am able to directly enter a channel number to execute the channel change.

Confirmaed by stuarta on IRC

  • stuarta fires up frontend

<stuarta> nope <stuarta> hitting enter, all i get is a message (on the log) "Clearing OpenGL painter cache"

The lines with CoreContext? mythpainter_ogl.cpp:62 (ClearCache?) Clearing OpenGL painter cache. Were the pressing of select in the guide.

I was using VDPAU, stuarta, VAAPI.

comment:2 Changed 2 years ago by Stuart Auchterlonie

Milestone: unknown0.28.1

comment:3 Changed 2 years ago by mcunning@…

Same issue here, with 3 HDHRs I am stuck on one tuner until I manually change the source or input. Worked in .27... broke on the upgrade. Spent 2 days trying to figure it out!

comment:4 Changed 2 years ago by wdirksen@…

I am experiencing this as well with 0.28, but not previously in 0.27, and it appears to be related to channel numbers and service ID numbers in mythtv-setup. In my case I am using DVB-S. If a fresh new channel scan is done all works well but you have to live with WAF unfriendly channel numbers. I can reproduce this error by altering channel numbers to something different from the matching service ID number. Any altered channel will tune with direct channel number tuning on the number pad only. If you alter all the channel numbers you will get the absurd situation that you can change channels by direct number input only in LiveTV but will not scroll at all and EPG states that it is completely empty. Affected channels also do not record as the EPG thinks the channel does not exist.

comment:5 Changed 2 years ago by sphery

#12751 marked as a duplicate of this one

comment:6 in reply to:  4 Changed 2 years ago by mythtv@…

Replying to wdirksen@…:

If a fresh new channel scan is done all works well

not really: did a clean install, empty db and everything from scratch. i have two dvbt cards an two dvbs. did a channel scan on dvbt, and a channel scan on dvbs. when i hit enter in the program guide to change channel, the program guide closes and nothing happens. changing channels by browsing with up/down keys in live tv and hitting enter, or entering the channel number + enter works every time.

comment:7 Changed 21 months ago by alex.l.williamson@…

0.28/fixes as of e6a60f7 still has this issue, a fix would be very much appreciated. Thanks.

comment:8 Changed 20 months ago by mcunning@…

I just confirmed directly entering the channel number does work, its just using the guide that doesn't work. Guide just closes and channel stays the same.

comment:9 Changed 20 months ago by mcunning@…

actually scratch that, I thought it was on antenna but it wasn't. when I press the up/down arrows while not in the guide it seemed to only give me channels on that source, not the ones from other sources.

comment:10 Changed 18 months ago by bmfisher@…

I also experience this with two OTA HDHomerun tuners with 0.28.0+fixes.20161206.2d6466f-0ubuntu0mythbuntu2. I can change channels using the EPG only when the next channel does not switch to the other tuner. Manual entry works.

comment:11 Changed 16 months ago by wdirksen@…

I am wondering if this issue has been identified specifically enough to allow for a fix. I tried 0.28 again recently with the same problem. Staying on 0.27 for now

comment:12 Changed 16 months ago by Stuart Auchterlonie

Milestone: 0.28.10.28.2

Moving remaining open 0.28.1 tickets to 0.28.2

comment:13 Changed 4 months ago by Stuart Auchterlonie

Resolution: Won't Fix
Status: newclosed

Closing any remaining tickets for 0.28, if the issue persists, feel free to reopen and align to v29 or master

Note: See TracTickets for help on using tickets.