Opened 4 years ago

Closed 2 years ago

Last modified 19 months ago

#12685 closed Patch - Feature (fixed)

Feature Patch: Properly detect CableCARD in Ceton tuner in cardutil.cpp

Reported by: Gary Buhrmaster <gary.buhrmaster@…> Owned by: Peter Bennett
Priority: minor Milestone: 30.0
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

"DO" the "TODO FIXME" in cardutil.cpp to properly detect if a CableCARD is inserted into a Ceton InfiniTV tuner (rather than just presume it is inserted, which is what the FIXME code did).

This code (as the HDHR code above it) leverages the existing approaches from the recorder specific handlers (i.e. most of the credit to others)

Lightly tested in master in a distant environment using remote smart hands to remove/insert a CableCARD into a Ceton InfiniTV for testing. Worked as expected.

As most people purchasing a Ceton InfiniTV tuner likely use a CableCARD, this update is likely a no-op for most.

Submitted as a feature, and not a bug, patch.

github ref: https://github.com/garybuhrmaster/mythtv/commit/08057e670dfa193793c8ceddf911328379b06b2b

github git-am ref: https://github.com/garybuhrmaster/mythtv/commit/08057e670dfa193793c8ceddf911328379b06b2b.patch

Change History (9)

comment:1 Changed 4 years ago by Stuart Auchterlonie

Milestone: unknown0.29

comment:2 Changed 4 years ago by Stuart Auchterlonie

Milestone: 0.2929.0

Milestone renamed

comment:3 Changed 4 years ago by Gary Buhrmaster <gary.buhrmaster@…>

See also #12756 which provides a likely desirable (but not required) improvement for channel inserts after this patch.

comment:4 Changed 2 years ago by Peter Bennett

Owner: set to Peter Bennett
Status: newassigned

comment:5 Changed 2 years ago by Peter Bennett

Status: assignedaccepted

comment:6 Changed 2 years ago by Peter Bennett

I tested on my Ceton eth6, this fix and #12756 together:

  • Cablecard inserted, mythfilldatabase inserts channels.
  • Cablecard removed, mythfilldatabase does not insert channels.
  • Watching LiveTV is ok while running mythfilldatabase to prove that cablecard detection does not disrupt recordings in progress.
  • Checked that added channel can be watched.

comment:7 Changed 2 years ago by Peter Bennett

Milestone: 29.030.0

comment:8 Changed 2 years ago by Gary Buhrmaster <gary.buhrmaster@…>

Resolution: fixed
Status: acceptedclosed

In 4fbeb0c3cc510c85195fc45c84bef4a9bc0b46ba/mythtv:

Setup: Properly detect CableCARD in Ceton tuner

Detect cable card in Ceton tuner instead of just assuming it is present

Fixes #12685

Signed-off-by: Peter Bennett <pbennett@…>

comment:9 Changed 19 months ago by Peter Bennett

Owner: changed from Peter Bennett to Peter Bennett
Note: See TracTickets for help on using tickets.