Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12689 closed Bug Report - Hang/Deadlock (fixed)

Mythfront media mount pop up lock

Reported by: bernhart2002@… Owned by: Roger Siddons
Priority: minor Milestone: 0.28.1
Component: MythTV - General Version: 0.28.0
Severity: medium Keywords:
Cc: Ticket locked: no

Description

on my frontend/backend TV I have 2 usb hard drives connected and when starting up the frontend I get a pop up message for

"The new media contains mixed content that can be rendered in different ways. Select your preferred method."

After selecting 1 of the 4 option the pop up window remains and keep the frontend locked up. The only way to get out of this is to hit the escape button. After hitting escape the frontend works normally. There is nothing in the log file about this.

I am using MythTV Version : v0.28-pre-3680-g514f7f8

from the mythbuntu PPA

I can send you a screen shot if it helps

Attachments (1)

Revert-20b621e5733-MediaMon-UI-to-select-preferred-m.patch (6.9 KB) - added by Roger Siddons 3 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 3 years ago by Roger Siddons

The pop-ups are intended to improve auto-play with media that has different media types on them (eg. photos & music)

The frontend isn't hanging/deadlocking. The code is displaying 2 modal pop-ups on top of each other - one for each of your USB sticks. If you action the top one the 2nd is cancelled (side-effect, not by design). However, if you cancel the first, you see the 2nd underneath ("the pop up window remains"), which has now lost focus. The only actions are then ESC or use a mouse to restore focus.

Displaying multiple pop-ups simultaneously isn't acceptable: having multiple media attached isn't handled properly.

Also the pop-ups don't respect the autoplay settings: they should only appear when auto-play is enabled by a plug-in. The only way to prevent them appearing if you have USBs permanently inserted, is by listing them in the "MediaMonitor? Ignore devices" setting, which isn't correct.

This feature should be reverted to prevent annoyance and the design re-considered.

Changed 3 years ago by Roger Siddons

comment:2 Changed 3 years ago by Roger Siddons

Milestone: 0.280.28.1
Owner: set to Roger Siddons
Status: newaccepted

comment:3 Changed 3 years ago by Roger Siddons <rsiddons@…>

Resolution: fixed
Status: acceptedclosed

In 24c5575980e5342e50d1354b7c11e6272463e93f/mythtv:

Revert 20b621e5733 MediaMon?: UI to select preferred media handler

The pop-ups don't cater for multiple media, nor respect the autoplay settings

Fixes #12689

comment:4 Changed 3 years ago by Roger Siddons <rsiddons@…>

In 4f6f75df4d4290cb82aae9ae01c3426db4d4f74b/mythtv:

Revert 20b621e5733 MediaMon?: UI to select preferred media handler

The pop-ups don't cater for multiple media, nor respect the autoplay settings

Fixes #12689

(cherry picked from commit 24c5575980e5342e50d1354b7c11e6272463e93f)

comment:5 Changed 3 years ago by warpme@…

Roger, many users will miss this code (and probably revert change). I i.e. have many CDs with mp3 and band pictures. It was useful to have pop-up with asking me: do I want to listen music or see pictures. Now - when I insert such CD - nothing happens - which is 1\missed functionality; 2\wrong behavior. I think more beneficial will be to fix OP issue (and finish this feature) instead of remove code to remove issue.

comment:6 Changed 3 years ago by stuartm

The patch was never correct to start with since it used the old deprecated UI popup. We'll accept patches to re-add this feature that utilise mythui, and which respects the user's preferences.

Note: See TracTickets for help on using tickets.