Opened 3 years ago

Closed 3 years ago

Last modified 12 months ago

#12730 closed Patch - Bug Fix (fixed)

Raspberry Pi: Intermittent pixelation with openmax decoder

Reported by: Peter Bennett <pgbennett@…> Owned by: Peter Bennett
Priority: minor Milestone: 0.28.1
Component: MythTV - Video Playback Version: 0.28.0
Severity: medium Keywords: Raspberry pi
Cc: Ticket locked: no

Description

Some MPEG2 streams cause pixelation during playback, from once every 30 seconds to once every few minutes.

I have determined the cause and I have a fix. I am currently testing it. I will attach the patch soon.

Attachments (1)

ticket_12730_pixelation.patch (677 bytes) - added by Peter Bennett <pgbennett@…> 3 years ago.
Patch to fix the bug.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 3 years ago by Peter Bennett <pgbennett@…>

The problem is caused by a timeout value too small. If the system waits more than 5 ms for a buffer for the next video packet, the packet is being dropped. The wait time will depend on decoder internals, the frame speed and how long it is until the next frame will be displayed. We do not want to drop packets in this situation. I set the timeout to 10000 so that in the event of a real decoder problem it will free up after 10 seconds. I also updated the message displayed to General, Error so that it will show in the log when default logging settings are used.

Changed 3 years ago by Peter Bennett <pgbennett@…>

Patch to fix the bug.

comment:2 Changed 3 years ago by Peter Bennett

Owner: changed from JYA to Peter Bennett
Status: newaccepted

comment:3 Changed 3 years ago by Peter Bennett <pbennett@…>

Resolution: fixed
Status: acceptedclosed

In 1691a428f43b8a22e78873518e1271cba4d7bb9d/mythtv:

Fix intermittent pixelation caused by timeout waiting for input buffers

Fixes #12730

comment:4 Changed 3 years ago by Peter Bennett <pbennett@…>

In 2008b9756a17e80008e28606c4dde253e10754f5/mythtv:

Fix intermittent pixelation caused by timeout waiting for input buffers

Fixes #12730

(cherry picked from commit 1691a428f43b8a22e78873518e1271cba4d7bb9d)

comment:5 Changed 12 months ago by Peter Bennett

Owner: changed from Peter Bennett to Peter Bennett
Note: See TracTickets for help on using tickets.