Opened 3 years ago

Closed 3 years ago

#12748 closed Bug Report - Crash (Works for me)

Segmentation Fault: on all parts of the system after instalation

Reported by: qwarlock@… Owned by:
Priority: minor Milestone: 0.28.1
Component: MythTV - General Version: 0.28.0
Severity: high Keywords:
Cc: qwarlock@… Ticket locked: no

Description

Hey guys,

Love the software. But I downloaded and installed 0.28 and everything hits a segmentation fault. Backend, and mythtv-setup. Frontend will open but says it needs and upgrade. Please run mythbackend or mythsetup to upgrade. I am not getting any information on where the seg fault is coming from. I downloaded and tried to get the git version up and it does exactly the same thing. Any hints on what I should do? I run Slackware current.

Attachments (1)

mythbackend.20160427220049.27140.log (14.3 KB) - added by qwarlock@… 3 years ago.
I get the same errors when pulling the 0.28 version

Download all attachments as: .zip

Change History (8)

comment:1 Changed 3 years ago by Stuart Auchterlonie

It sounds like you have libraries from multiple versions installed. Remove any packages, remove any libmyth* libraries, and then reinstall mythtv

(You should keep the database, no need to remove that)

comment:2 Changed 3 years ago by qwarlock@…

Hey Guys,

I removed all packages and then searched for any libraries. I did not find any. I reinstalled and still got seg faults. when I turn off mysqld and run setup there are no seg faults. When I run the backend with no database running it starts and say would you like to create a database connection. But there are no seq faults.

comment:3 Changed 3 years ago by qwarlock@…

oops but yea when the database is turned on both backend and setup seg fault out.

Changed 3 years ago by qwarlock@…

I get the same errors when pulling the 0.28 version

comment:4 Changed 3 years ago by qwarlock@…

Could this be that it crashing as it starts trying to upgrade the database? the front end is saying it is 37 versions behind even tough I dropped the database and restarted it from the included scripts. did I miss something? If I am starting with your new script how can it be behind?

comment:5 Changed 3 years ago by Stuart Auchterlonie

We will need to get a backtrace from the crash to have any idea of what is going on here.

Please capture a backtrace using the instructions in https://www.mythtv.org/wiki/Debugging

comment:6 Changed 3 years ago by Stuart Auchterlonie

Milestone: unknown0.28.1
Status: newinfoneeded_new

Does this still occur? Has anyone managed to capture a backtrace as requested?

Regards Stuart

comment:7 Changed 3 years ago by Stuart Auchterlonie

Priority: criticalminor
Resolution: Works for me
Status: infoneeded_newclosed

Without any further information being provided, we are unable to determine what the possible cause of this is.

So at this time, i'm closing this as "Works for me"

Feel free to reopen with the requested information.

Regards Stuart

Note: See TracTickets for help on using tickets.