Opened 4 years ago

Closed 3 years ago

#12763 closed Bug Report - General (Fixed)

Themechooser parses version number incorrectly

Reported by: Peter Bennett <pgbennett@…> Owned by: Karl Egly
Priority: minor Milestone: 0.28.1
Component: MythTV - General Version: 0.28.0
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have mythtv version v0.28-61-g5af4b41 and the backend displays 61 error messages when it starts up:

2016-05-10 11:21:09.927411 I  Running HouseKeeperTask 'ThemeUpdateNotifications'.
2016-05-10 11:21:09.927471 I  Loading themes for 0.28
2016-05-10 11:21:10.776129 I  Loading themes for 0.28.61
2016-05-10 11:21:10.976677 I  HouseKeeper: Failed to download http://themes.mythtv.org/themes/repository/0.28.61/themes.zip remote themes info package.

That 0.28.61 messages are repeated with numbers going down to 0.28.1. This seems to be caused by parsing the "-61" in the version string as if it was ".61" This will likely also affect the front end, which duplicates some code.

mythtv/programs/mythfrontend/themechooser.cpp#L202

mythtv/programs/mythbackend/backendhousekeeper.cpp#L366

Also it would be good to refactor the code so that it is not duplicated.

Change History (7)

comment:1 Changed 4 years ago by Karl Dietz <dekarl@…>

In f4a8cf1673dcbaa649e3879b8716d3942474f2dd/mythtv:

fix parsing of version numbers in theme updater

the separator between the parts of the version number is a literal
period (
.), not any character (.)

Refs #12763

comment:2 Changed 4 years ago by Karl Dietz <dekarl@…>

In b092e46a56874cb395e118bd46a2b2f8d5c3cfda/mythtv:

update version parser in themechooser for v29 (without leading 0.)

there are likely other places that need to be adjusted for the missing

  1. prefix

Refs #12763

comment:3 Changed 4 years ago by Karl Egly

Milestone: unknown0.28.1
Owner: set to Karl Egly
Status: newaccepted

No point in porting to 0.27 (if its even an issue there) as the bug is only between 0.27 and 0.27.1 and that has long been released, so a fix will only make it into a version that doesn't trigger the bug.

comment:4 Changed 4 years ago by Karl Dietz <dekarl@…>

In 370dd71fa4a6affb09f989c6000c9dea7097bb15/mythtv:

fix parsing of version numbers in theme updater

the separator between the parts of the version number is a literal
period (
.), not any character (.)

Refs #12763

(cherry picked from commit f4a8cf1673dcbaa649e3879b8716d3942474f2dd)

comment:5 Changed 3 years ago by Karl Egly

Status: acceptedinfoneeded

Peter, can you confirm this as fixed?

I only run master and its nicely saying "I HouseKeeping? backendhousekeeper.cpp:380 (DoRun?) Loading themes for trunk" on startup

comment:6 Changed 3 years ago by Peter Bennett

Karl Yes this is fixed. I have not seen that error in 4 months, since you made that fix.

comment:7 Changed 3 years ago by Karl Egly

Resolution: Fixed
Status: infoneededclosed
Note: See TracTickets for help on using tickets.