Opened 13 years ago

Closed 13 years ago

#1280 closed defect (invalid)

Setting Global Escape Makes Frontend Unusable

Reported by: Guardian.Bob@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythcontrols Version: 0.19
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I wanted my escape keybinding to be ctrl-escape. When using the keybinding editor, I changed the global escape key, and saved my changes. The keybinding editor would not exit. Furthermore, neither escape nor ctrl-escape would exit. Restarting the front end, I found that I could not escape from any menu. I had to edit the database directly to fix.

Change History (7)

comment:1 Changed 13 years ago by cpinkham

I think you can use MythWeb to edit keybindings to correct for this situation so no direct hand-editing of the database is necessary. Also, did you try changing the key sequence back to just plain ESCape instead of exiting the screen? Is your exit key for mythfrontend set to CTRL + ESCape or have you left that at just ESCape?

comment:2 Changed 13 years ago by Jonas Anden

Just a long shot: KDE (at least as per the default settings in FC4) hooks Ctrl-ESC to start the KDE process monitor. It will start in the background (since mythfrontend runs in full-screen mode). Try setting the key to Alt-ESC instead; that worked for me.

comment:3 Changed 13 years ago by Guardian.Bob@…

Jonas,

While that makes sense, how does Ctrl-Esc as an exit key work then? Furthermore, if that is true, shouldn't the frontend disallow that binding?

comment:4 Changed 13 years ago by Jonas Anden

Since the key combination is hooked by KDE, the keystroke will never reach the application (in this case mythfrontend), and hence it cannot react to it.

But you're not *required* to run KDE as your window manager (although it is recommended). And it is possible to reconfigure the KDE shortcut keys to use another key combination to start the process monitor.

I see no reason to disallow the combination in the frontend. Perhaps a warning in the docs.

comment:5 Changed 13 years ago by Guardian.Bob@…

Ah I mis-understood you. I'm not running mythtv in any wm. I use startx to start mythtv in it's own xserver. KDE isn't even installed on my system (I use gnome with e16.)

I use this line to start mythtv: startx /usr/bin/mythfrontend -- :2 -br dpms -v nologo -s 0

Basically, no screen saver, black background, no logo and turn on energy star.

comment:6 Changed 13 years ago by Guardian.Bob@…

Version: head0.19

cpinkham

I had to edit the db directly, as the rewrite commands for mythweb do not appear to work correctly on my gentoo box. If a user cannot get mythweb running then they are SOL when it comes to fixing key bindings. As for changing back to escape, I couldn't exit (as ctrl-esc wasn't working) the key binding manager to make it save my changes. When I edited the db directly, I set exit back to esc (as I didn't want to experiment and really bork things.) My Quit key for the frontend is alt-esc right now, but I have tried ctrl-esc and that has worked fine. Since we are talking about the quit key, (as opposed to the global exit key) why (provided that it is diffrent from the exit key) doesn't it quit the front end from wherever you are?

comment:7 Changed 13 years ago by bjm

Resolution: invalid
Status: newclosed

This is not a bulletin board nor a helpdesk system. Please post questions to the mailing lists.

Note: See TracTickets for help on using tickets.