Opened 3 years ago

Closed 7 days ago

#12800 closed Bug Report - Crash (Upstream Bug)

mythfilldatabase segfault just before finished

Reported by: Eric Fontaine <ericrfontaine@…> Owned by: stuartm
Priority: minor Milestone: 30.1
Component: MythTV - Mythfilldatabase Version: 0.28.0
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Fresh mythtv backend install on parabola (arch) linux x86-64. I'm able to setup backend and record shows and whatnot, but I'm getting this segfault before exit (although I believe most of mythfilldatabase completes, since I can see the guide data in frontend).

Thread 7 "Qt bearer threa" received signal SIGSEGV, Segmentation fault. [Switching to Thread 0x7fffcaffd700 (LWP 7454)] QDBusMetaType::typeToSignature (type=8) at qdbusmetatype.cpp:437

See attached gdb console output and backtrace.

I should note that my computer is on Qt version 5.6.0.

Attachments (2)

mythfilldatabase_gdb.txt (11.0 KB) - added by Eric Fontaine <ericrfontaine@…> 3 years ago.
gdb console
mythfilldatabase_backtrace.txt (3.2 KB) - added by Eric Fontaine <ericrfontaine@…> 3 years ago.
backtrace

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by Eric Fontaine <ericrfontaine@…>

Attachment: mythfilldatabase_gdb.txt added

gdb console

Changed 3 years ago by Eric Fontaine <ericrfontaine@…>

backtrace

comment:1 Changed 3 years ago by Gary Buhrmaster <gary.buhrmaster@…>

Just a FYI to the devs: I cannot (quickly) find the reference, but I have seen something like this reported for other (non-MythTV) apps with Qt 5.6.0. I suspect it is upstream. As I (vaguely) recall, it may have to do with Qt's final cleanup processing (and possibly QNetworkAccessManager?). It might also be timing related (so it may not always crash, either).

Btw, to the OP, with schedules direct, presuming your system is not under-powered, using the --dd-grab-all option is usually recommended (but I suspect it would not change the crash, unless it changes the timing sufficiently so that you get "lucky").

comment:2 Changed 3 years ago by Karl Egly

Component: MythTV - GeneralMythTV - Mythfilldatabase
Owner: set to stuartm

comment:3 Changed 2 years ago by falk0069@…

Looks like I have the same problem and the fix is probably to upgrade Qt from 5.6 to 5.7. I'm running Centos7 and they do not have 5.7 available yet, so I'll probably just wait it out since the job completes. It is just annoying to see the daily core [abrt] report appear in my inbox.

Here are a couple of related threads: https://stackoverflow.com/questions/37986256/qt-qtest-segmentation-fault-at-end-of-execution

https://bugreports.qt.io/browse/QTBUG-52988?focusedCommentId=325416&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-325416

comment:4 Changed 7 days ago by Gary Buhrmaster

This ticket should (probably) be closed as upstream bug, as it was acknowledged as Qt 5.6 issue, and was resolved (upstream) quite some time ago (including for the OPs OS).

comment:5 Changed 7 days ago by gigem

Milestone: unknown30.1
Resolution: Upstream Bug
Status: newclosed
Note: See TracTickets for help on using tickets.