Opened 14 years ago

Closed 14 years ago

#1281 closed defect (invalid)

Changing Groups Caused Loss of Recorded Entry in the Database

Reported by: Guardian.Bob@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I had three recordings in a group called "Dad" left over from mythtv 0.18.1. After I upgraded to MythTv? 0.19, I changed the recording group on one of these files to "Default." As a result, the file isn't listed under the Default group or the Dad group. It doesn't even show up under the All Recordings filter. The nuv file still exists, meaning the recorded entry was deleted rather than changed.

I haven't confirmed if this is just a result of using old style (filename) files or because they are moving to the default group. However, that being said, what would help (other than to fix the bug) is a simple script to re-add recordings in a directory to the database if they do not already exist. (I see this script as something useful even if this bug is fixed.)

Change History (3)

comment:1 Changed 14 years ago by cpinkham

Resolution: worksforme
Status: newclosed

All the code does is an update on the recorded table, so this does not sound like the issue. I do this all the time and have never lost a recording as you are indicating. There is also a script already in the contrib directory to re-add recordings to the database, so that part of this "bug" report is invalid as well. Marking this as "works for me" unless you can provide the "mythfrontend -v database" SQL output showing that Myth is deleting the record instead of changing the recgroup.

comment:2 Changed 14 years ago by Guardian.Bob@…

Resolution: worksforme
Status: closedreopened

There is a bug somewhere here, I just haven't figured out exactly what triggers it.

Basically, the program which I lost when changing groups came back (I left the front end running all day, and it showed up in the evening.) Again, this morning I changed groups for this recording (old group, but it was empty) and it disappeared. I suspect it will show again. When it does, (and I get home) I could take screen shots to show what is happening.

What can I do to provide better details on this bug?

comment:3 Changed 14 years ago by bjm

Resolution: invalid
Status: reopenedclosed

The is not a bulletin board nor a helpdesk system. Please post questions to the mailing lists.

Note: See TracTickets for help on using tickets.