Opened 23 months ago

Last modified 23 months ago

#12840 new Bug Report - General

OSD Text Squashed with Anamorphic Content

Reported by: tom@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Video/OSD Rendering Version: 0.28.0
Severity: medium Keywords:
Cc: pbennett@… Ticket locked: no

Description

Since upgrading to 0.28 it seems that text in the OSD is being squashed horizontally when viewing anamorphic content - the narrow the original content the narrower the text.

I'm using the Muthbuntu theme, where this seems to happen to all the OSD text but most themes show the same effect on at least some text, and often on all text.

I'm attaching two screenshots, both of 16x9 content but the first is an HD transmission with a native resolution of 1920x1280 and normal sized text and the second is a sub-SD transmission with a native resolution of 544x576 and particularly narrow text.

Attachments (4)

1920x1080.jpg (174.0 KB) - added by tom@… 23 months ago.
Example of 1920x1280 transmission with normal text
544x576.jpg (121.7 KB) - added by tom@… 23 months ago.
Example of 544x675 transmission with narrow text
1280x720.mp4 (1.0 MB) - added by tom@… 23 months ago.
1280x720 test video
544x576.mp4 (674.3 KB) - added by tom@… 23 months ago.
544x576 test video

Download all attachments as: .zip

Change History (9)

Changed 23 months ago by tom@…

Attachment: 1920x1080.jpg added

Example of 1920x1280 transmission with normal text

Changed 23 months ago by tom@…

Attachment: 544x576.jpg added

Example of 544x675 transmission with narrow text

comment:1 Changed 23 months ago by Peter Bennett

What is your OSD rendering method? (In frontend, Setup->Playback->Playback Profile, edit) You may have different settings for different resolutions in your playback profile. Check the values for each and let us know what you have.

If you have softmerge then the OSD will be compressed to fit the video image resolution. In that case you can change to another rendering method, such as opengl, if one is available in your selection list.

comment:2 Changed 23 months ago by Peter Bennett

Cc: pbennett@… added

comment:3 Changed 23 months ago by tom@…

I was actually just playing with that to see if I could find anything that would make a difference.

My current profile is using the openglvaapi renderer with the opengl2 OSD renderer, which is the only OSD renderer option with that renderer by the looks of it.

Switching to the XVideo renderer with the softblend OSD renderer did appear to fix the font squashing but anything using the opengl2 OSD renderer appears to suffer from the problem

comment:4 Changed 23 months ago by Peter Bennett

I am unable to reproduce this, but we do not have any anamorphic TV channels as far as I know.

Does this happen if you select video renderer as OpenGL?

Have to set in Setup->Appearance to select different screen resolutions for different video sizes?

Changed 23 months ago by tom@…

Attachment: 1280x720.mp4 added

1280x720 test video

Changed 23 months ago by tom@…

Attachment: 544x576.mp4 added

544x576 test video

comment:5 Changed 23 months ago by tom@…

It does happen with the opengl renderer, yes - that's what I was using when I first upgraded.

I've attached couple of test videos - a 1280x720 original that has a natural 16:9 aspect ratio and a rescaled 544x576 version that declares a 16:9 display aspect so that it has to be stretched.

Having said all that I have discovered what in my setup is triggering it, and how to fix it...

I had my GUI resolution set to 1912x1080 so that it wasn't quite full HD size. I think that was because I used to have issues with losing a bit of the menus at the side or something. Changing that to 1920x1080 resolves the problem.

It's still a very dramatic effect for an eight pixel difference though, and 0.27 didn't do it.

Note: See TracTickets for help on using tickets.