Opened 3 years ago

Closed 3 years ago

Last modified 18 months ago

#12864 closed Bug Report - General (fixed)

Screen paint problem with QT painter and certain themes

Reported by: Peter Bennett Owned by: Peter Bennett
Priority: minor Milestone: 0.28.1
Component: MythTV - User Interface Library Version: 0.28.0
Severity: medium Keywords:
Cc: jpoet@… Ticket locked: no

Description

There is a strange effect with Steppes menus when using QT Theme Painter. The menu buttons are drawn outside the menu box. With OpenGL Theme Painter the menu is correct. This problem has existed for years, but I am concerned because with Raspberry Pi we have to use the QT Theme Painter. I have not seen this with other themes.

Photo of screen with messed up menu -> https://drive.google.com/open?id=0B-SLdaEBcVYkTGpzYjVPbkhVRFk

Photo of screen with correct menu -> https://drive.google.com/open?id=0B-SLdaEBcVYkVkNQOVJXZ1RNam8

I am working on a fix for this. It seems to be a bug in the way MythTV is drawing dynamic layouts, that are supposed to expand to fit the contents.

Change History (4)

comment:1 Changed 3 years ago by Peter Bennett

This problem is caused by incorrect calculation of the dialog size. The dialog size is being recalculated during painting, but after the dialog outline and background have already been painted. I solved it by adding a call to calculate the dialog size earlier, to fix the error for dynamic dialogs and menus. This could potentially happen with anything that uses a button list. MythDialogBox dialogs and menus are the only places I found where a button list is used in a dynamic layout.

comment:2 Changed 3 years ago by Peter Bennett <pbennett@…>

Resolution: fixed
Status: newclosed

In 88910460184e73fe203a90b6c45e3e5b26e56153/mythtv:

Fix paint problem with QT dynamic button lists. This affected Steppes theme, maybe others.

Fixes #12864

comment:3 Changed 3 years ago by Peter Bennett <pbennett@…>

In 880d3a3a0e72c26d4a241f1c51f91498747430e3/mythtv:

Fix paint problem with QT dynamic button lists. This affected Steppes theme, maybe others.

Fixes #12864

(cherry picked from commit 88910460184e73fe203a90b6c45e3e5b26e56153)

comment:4 Changed 18 months ago by Peter Bennett

Owner: changed from Peter Bennett to Peter Bennett
Note: See TracTickets for help on using tickets.