Opened 3 years ago

#12924 new Bug Report - General

Recordings from DCX3510-M occasionally start in a way that built-in player does not like

Reported by: sim@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.28.0
Severity: medium Keywords: firewire
Cc: Ticket locked: no

Description

Hello! I recently added a DCX3510-M to the mix, and it works fairly well (ignoring slow channel change sync and 6200ch not understanding power on/off state) except that occasionally, recordings captured from it are written in a way that the built-in player does not like. It hangs waiting for video buffers and, after a long time, eventually gives up with "Video frame buffering failed too many times."

If I play the .ts file with mplayer (1), it spits these errors, but plays anyway:

[ac3 @ 0x560c2f409760]exponent -1 is out-of-range

[ac3 @ 0x560c2f409760]error decoding the audio block

[ac3 @ 0x560c2f409760]frame sync error

ffplay also plays it, but mplayer 2 and MythTV do not.

I found that just the first 2MB of the file is enough to demonstrate the issue, so I've attached that here.

The firewire backend is set to "Motorola Generic" as there is no more specific version for this model, which, BTW, shows up as vendor 0x1be9, model 0x7420.

Attachments (1)

mythtv_ref.ts (2.0 MB) - added by sim@… 3 years ago.
head -c2m of sample stream

Download all attachments as: .zip

Change History (1)

Changed 3 years ago by sim@…

Attachment: mythtv_ref.ts added

head -c2m of sample stream

Note: See TracTickets for help on using tickets.