Opened 2 years ago

Closed 2 years ago

#12927 closed Bug Report - General (Invalid)

Storage Group Space not correct

Reported by: clueo8@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.28.0
Severity: medium Keywords:
Cc: Ticket locked: no

Description

mythbackend version: fixes/0.28 [v0.28-80-g43fcdd9] www.mythtv.org

I recently added 2 x 4TB NAS drives (8TB total) nfs mounts to the MythTV storage group (added it as 2 new groups with a custom name; originally tried adding both drive paths under a single storage group, same outcome). The drives are both mounted under separate directories like so: 192.168.X.X:/mnt/HD/HD_a2 /mnt/mycloud nfs auto,nolock 0 0 192.168.X.X:/mnt/HD/HD_b2 /mnt/mycloud_2 nfs auto,nolock 0 0

The storage group paths are: /mnt/mycloud/mythtv/recordings/ /mnt/mycloud_2/mythtv/recordings/

In both mythweb backend status as well as mythfrontend status, its reporting it as a single drive with only 4TB free (I expect to see 8TB free):

MythTV Drive #4: Directories: Ubuntu-Server:/mnt/mycloud/mythtv/recordings, Ubuntu-Server:/mnt/mycloud_2/mythtv/recordings Total Space: 3,751,507 MB Space Used: 38,329 MB Space Free: 3,713,177 MB <- This should be 8TB, not 4TB.

I have another NAS device also with 2 drives that is reporting the space correctly (as two separate drives in myth status), but for some reason myth is thinking this one is a single drive with only 4TB free instead of 8TB. The only difference there is that I have both those drive paths added to the "Default" storage group, not a custom named storage group.

Change History (3)

comment:1 Changed 2 years ago by stuartm

Since both drives are empty and otherwise identical, mythbackend can't tell them apart. For all it knows the NFS mounts point to the exact same drive. Until there is content on one or both of the drives it's unable to tell them apart.

comment:2 Changed 2 years ago by clueo8@…

You are absolutely correct; I just did a recording to one of the drives and now it's reporting correctly as two separate drives. Thank you for this information.

comment:3 Changed 2 years ago by Stuart Auchterlonie

Resolution: Invalid
Status: newclosed

Not a bug, closing

Note: See TracTickets for help on using tickets.