Opened 3 years ago

Closed 3 years ago

#12937 closed Bug Report - General (Invalid)

LiveTV not working with 0.28

Reported by: hwintjen@… Owned by: JYA
Priority: major Milestone: 0.28.1
Component: MythTV - Recording Version: 0.28.0
Severity: high Keywords: livetv
Cc: Ticket locked: no

Description

Hi Folks.

I was running MythTV 0.27 for quite some time now on Ubuntu 12.04 sucessfully.

After upgrading to Ubuntu 16.04 and MythTV 0.28 some problems came up.

The most important one is that i am unable to watch live TV after the most recent upgrade to 2:0.28.0+fixes.20161106.1434df8- 0ubuntu0mythbuntu3 over 2:0.28.0+fixes.20161023.7f8f168- 0ubuntu0mythbuntu3 from the PPA.

I can no longer connect to LiveTV via MythFrontend nor via Kodi (LibreElec?) client.

Recordings still work fine.

After downgrading to the version 20160413.15cf421 the problem still exists.

As it looks, i am able to watch LiveTV after backend startup for some time, but after about 1d tuning to a channel will not work (timeout?).

I tried also several mysql tunings, but with no luck yet. Any help would be appreciated.

Kind regards

Hauke

Attachments (1)

mythbackend.log (15.4 KB) - added by hwintjen@… 3 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 3 years ago by JYA

Status: newinfoneeded_new

Please provide the errors you are seeing. "It doesn't work" is not sufficient information to diagnose the problem..

Please start mythfrontend with --loglevel=debug -v audio,playback and save the output of the console to a file and attach it here..

comment:2 Changed 3 years ago by hwintjen@…

Hi JVavenard. Thanks for your feedback. I did enable debug for the running backend with

mythbackend --setverbose general:debug,playback:debug,audio:debug

since it appears only after some uptime. Hope that is sufficient.

By not working i mean: I try to Live-watch a channel from my Kodi LibreElec?-PI client. I press a channel and the waiting-wheel starts to spin until the Kodi decides to crash/restart without starting any video.

Changed 3 years ago by hwintjen@…

Attachment: mythbackend.log added

comment:3 Changed 3 years ago by hwintjen@…

The line

Nov 24 20:42:27 mediasrv mythbackend: mythbackend[5315]: D ProcessRequest livetvchain.cpp:32 (LiveTVChain) LiveTVChain(): ctor

shows the time at which i selected the channel to watch and the waiting spin wheel starts. When the log shows the LibreElec? disconnect, this most probably is the kodi client crash.

When trying with MythFrontend, i get similair behavior, the client waits some time after i select "Watch TV" and then returns to the selection screen without having started a playback (but without crash).

comment:4 Changed 3 years ago by Hauke Wintjen <hwintjen@…>

The issue seems to be resolved. It was caused by my attempt to optimize MySQL performance over ZFS filesystem according to https://blogs.oracle.com/realneel/entry/mysql_innodb_zfs_best_practices ...

As it turns out, setting the blocksize to 128K and disabling ZFS cachin revealed as a MySQL performance killer which lead to LiveTV timeouts.

So this ticket can be closed,

comment:5 Changed 3 years ago by Stuart Auchterlonie

Milestone: unknown0.28.1
Resolution: Invalid
Status: infoneeded_newclosed

Thanks for reporting back, closing.

Note: See TracTickets for help on using tickets.