Opened 2 years ago

Closed 2 years ago

Last modified 12 months ago

#12955 closed Bug Report - General (fixed)

After ffmpeg v3.2 resync DVD playback is without Audio

Reported by: warpme@… Owned by: Peter Bennett
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After ffmpeg resync to v3.2, DVD playback is without audio. Playback data reports codec as "NONE" and audio channels number as -1. Tested on one DVD disc and one .iso image. Log with audio, playback attached.

Attachments (1)

log.txt (135.1 KB) - added by warpme@… 2 years ago.
FE log

Download all attachments as: .zip

Change History (12)

Changed 2 years ago by warpme@…

Attachment: log.txt added

FE log

comment:1 Changed 2 years ago by J.Pilk@…

I'm seeing this too, in F24 v0.29-pre-229 on MythArchive?-based DVDs and .iso files with mp2 audio throughout. And navigation is broken too. The title menu has no selection mask and doesn't work. Eventually video plays, but with no sound, audio playback data NONE, -1 as above. The chapter menu is active and has sound.

I've had difficulties with vlc too, but put that down to uncertain media support in SL7. The current vlc 3.0.0-0.11.fc24 from rpmfusion seems ok for dvd playback.

comment:2 Changed 2 years ago by J.Pilk@…

I noted above that the Chapter menu is active. From there M > Navigate > Title menu, is active, sometimes with sound, sometimes mute. The selected track plays, usually with sound when the menu was quiet, and v v. Going direct from the chapter menu may or may not have sound. v29-pre-239.

comment:3 Changed 2 years ago by warpme@…

Indeed it looks like ffmpeg resync broke DVD navigation and sound problems are probably because navigation part selects wrong sound config/track. I can't get sound at all for DTS disks. For DD5.1 discs I have high chances for sound if playback is from bookmark (but with 3-7sec silence at playback beginning). If I want to play disk from disc MainMenu? - it is almost impossible to get playback with sound as navigation is broken. I suspect when DVD navigation will be fixed - probably 5.1 sound discs will work OK. I suspect DTS issue is separate issue however....

comment:4 Changed 2 years ago by Peter Bennett

Owner: set to Peter Bennett
Status: newaccepted

This looks like the same issue as #13025. Fixing both of them together.

comment:5 Changed 2 years ago by Peter Bennett

Please test the patch file https://code.mythtv.org/trac/attachment/ticket/13025/20170413_streamchange.patch that is attached to ticket #13025

I tested this with videos, recordings and DVD playback. The changes also affect Blu Ray playback, but I am unable to test that.

comment:6 Changed 2 years ago by warpme@…

Peter, patch seems to be working perfectly. I tested this on 2 testing problematic DVDs and both are OK. I tested also BLuRay - it works OK also. Great work!

comment:7 Changed 2 years ago by J.Pilk@…

Yes: new build of 29-pre-386 with patch, via fc25 rpms. Initially failed to update database schema but then succeeded. First show of DVD title menu has no selection mask, but that appears after calling the menu OSD and thereafter all seems to be as intended. Thank you!

comment:8 Changed 2 years ago by J.Pilk@…

A new build with the updated patch (20170414...) also works for me, in fc25. The first show of the DVD title menu now has an active but invisible selection mask, and seems to be logged as

AFD_DVD: DVD context missed!

The mask will appear on selecting 'Navigation', or on exit from a playing track. Not as expected, but it seems reliable and usable.

Playback of the recording clip in #13025 has sound both before and after the stream changes, with a brief black-screen transition.

Now to see if 'mock' will rebuild the SRPM for SL7...

Thanks again.

comment:9 Changed 2 years ago by Peter Bennett <pbennett@…>

Resolution: fixed
Status: acceptedclosed

In ae81146402f86410fddb04f08776de955e14593c/mythtv:

Fix stream change handling in playback

In some cases, stream changes occurring in the video cause sound
and subtitles to be lost. This started with ffmpeg version 3.2.
This fixes the problem by changing the way stream changes are handled.

Fixes #13025
Fixes #12955

comment:10 Changed 2 years ago by J.Pilk@…

For completeness: the DVD menu mask delay in comment 8 is new, but is made more noticeable by a non-standard menu 'length' of 30s in my version of the MythCenter_-_Animated DVD theme. I forget why I changed it. The mask auto-appears after the delay. And my fc25 specfile needed minor changes for SL7 (use MySQL-python, don't require mesa-vdpau-drivers) - which I see had already been applied at rpmfusion when they added el7 support. The result seems to be running well.

comment:11 Changed 12 months ago by Peter Bennett

Owner: changed from Peter Bennett to Peter Bennett
Note: See TracTickets for help on using tickets.