Opened 3 years ago

Closed 3 years ago

#12959 closed Bug Report - General (Fixed)

mythfrontend 0.28 livetv does not display input connection display name on 'C' or 'Y' anymore

Reported by: Robert Watson <robertabcdefgwatson@…> Owned by: jpoet
Priority: minor Milestone: 0.28.1
Component: MythTV - Video/OSD Rendering Version: 0.28.0
Severity: low Keywords: OSD livetv switchcard switchinput
Cc: Ticket locked: no

Description

I recently updated to MythTV0.28 and noticed this problem. As it is a small problem and well defined, I thought I would have a look at it myself. I am proposing a fix but as this is my first time looking into MythTV I would like someone else to have a look at the proposed fix. Also, to be completely honest, I don't know 100% why the fix works.

I am a complete newbie when it comes to open source and creating/fixing bugs so forgive my errors but do let me know where I could do better.

The fix is in tv_play.cpp, method TV::SwitchInputs() and the entire fix is to swap these two lines:

UpdateOSDInput(ctx);
UnpauseLiveTV(ctx);

The Master branch appears to have the same issue when I look at the code so I suspect the bug has not been dealt with by anyone. Please note I have not compiled or test the master branch, only my code change in 0.28.

Attachments (1)

ticket12959.patch (401 bytes) - added by Robert Watson <robertabcdefgwatson@…> 3 years ago.
git diff output as requested

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by Robert Watson <robertabcdefgwatson@…>

Attachment: ticket12959.patch added

git diff output as requested

comment:1 Changed 3 years ago by Stuart Auchterlonie

Milestone: unknown0.28.1
Owner: set to jpoet
Status: newassigned

comment:2 Changed 3 years ago by jpoet

Resolution: Fixed
Status: assignedclosed

Fixed in [f2eac57151f]

Note: See TracTickets for help on using tickets.