Opened 2 years ago

Closed 2 years ago

#12967 closed Bug Report - Crash (Duplicate)

mythpreviewgen alignment trap on armhf

Reported by: Peter Barker <pb@…> Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Mythpreviewgen Version: 0.28.0
Severity: high Keywords: armhf alignment trap
Cc: Ticket locked: no

Description

mythpreviewgen crashes on odroid-xu4 (ARMv7 processor) backend for all recorded TV shows from Australian TV. Get Alignment trap and Unhandled fault every time it is run, either by backend automatically, or from command line.

Example command line: mythpreviewgen --size 0x0 --chanid 1002 --starttime 20090104112500 --outfile /home/share/public/TV/1002_20090104222500.mpg.png

I have attached relevant parts of syslog output. I enabled apport and ran under gdb - crash report attached

Attachments (5)

myth.version (886 bytes) - added by Peter Barker <pb@…> 2 years ago.
myth version output
kern.log (454 bytes) - added by Peter Barker <pb@…> 2 years ago.
kernel syslog errors
mythpreviewgen.log (10.4 KB) - added by Peter Barker <pb@…> 2 years ago.
mythpreviewgen syslog output
_usr_bin_mythpreviewgen.123.crash (51.8 KB) - added by Peter Barker <pb@…> 2 years ago.
gdb output, with core dump removed
gdb.txt (23.9 KB) - added by Peter Barker <pb@…> 2 years ago.
gdb backtrace

Download all attachments as: .zip

Change History (9)

Changed 2 years ago by Peter Barker <pb@…>

Attachment: myth.version added

myth version output

Changed 2 years ago by Peter Barker <pb@…>

Attachment: kern.log added

kernel syslog errors

Changed 2 years ago by Peter Barker <pb@…>

Attachment: mythpreviewgen.log added

mythpreviewgen syslog output

Changed 2 years ago by Peter Barker <pb@…>

gdb output, with core dump removed

comment:1 Changed 2 years ago by Gary Buhrmaster <gary.buhrmaster@…>

You did not include a backtrace, but the description appears to be equivalent to the issue already reported in ticket #12888 which you can presumably validate by applying the patch in that ticket to confirm the bug goes away (that patch is not a fix, but could verify it is the same bug)

Changed 2 years ago by Peter Barker <pb@…>

Attachment: gdb.txt added

gdb backtrace

comment:2 Changed 2 years ago by Peter Barker <pb@…>

It seems to be same bug as ticket #12888. I compiled branch fixes/0.28 from github, configured with ./configure --prefix=/home/mythtest/build --enable-libzvbi --compile-type=profile and got same error. Backtrace attached. (gdb.txt). I made change suggested in #12888 and a png file was produced with no error, but was not a correct preview.

comment:3 Changed 2 years ago by loomy <loomy@…>

same on bananapipro, built from 98021027d382963203c7

alignment trap

[37990.750151] Alignment trap: not handling instruction f902602d at [<b6f26924>]
[37990.750168] Unhandled fault: alignment exception (0x801) at 0xa477b008
[37990.750174] pgd = ed7f4000
[37990.750180] [a477b008] *pgd=5b2ec835, *pte=496c655f, *ppte=496c6c7e
[37999.501879] Alignment trap: not handling instruction f902602d at [<b6e92924>]
[37999.501893] Unhandled fault: alignment exception (0x801) at 0xa437b008
[37999.501898] pgd = ed7e4000
[37999.501903] [a437b008] *pgd=5b026835, *pte=541f555f, *ppte=541f5c7e

tried with en-/ and disabled vdpau. thought this might be the problem, but isnt

comment:4 Changed 2 years ago by Peter Bennett

Resolution: Duplicate
Status: newclosed

Duplicate of #12888

Note: See TracTickets for help on using tickets.