Opened 2 years ago

Closed 17 months ago

#13004 closed Bug Report - General (Won't Fix)

Backend does not shutdown correctly, needs to be asked twice

Reported by: Stuart Auchterlonie Owned by: Stuart Auchterlonie
Priority: major Milestone: 0.28.2
Component: MythTV - General Version: 0.28.0
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The backend doesn't shutdown cleanly when asked to. It requires a second shutdown request to fully shutdown.

This bites users who use mythtv-setup to shutdown their backend and proceed thinking it has shutdown, when in fact it's only half shutdown.

Attachments (1)

1kill.patch (741 bytes) - added by jpoet 2 years ago.
Don't trap SIGINT and SIGTERM

Download all attachments as: .zip

Change History (5)

comment:1 Changed 2 years ago by Peter Bennett

Is this a duplicate of #12724 ?

Changed 2 years ago by jpoet

Attachment: 1kill.patch added

Don't trap SIGINT and SIGTERM

comment:2 Changed 2 years ago by jpoet

I remember asking Gavin why it worked that way, and he had a reason. I don't remember now what the reason was, though...

comment:3 Changed 2 years ago by Stuart Auchterlonie

Interesting, although i'm not convinced this is totally it. Some of the threads do shutdown when requested and at least my dev backend issues a warning about posting to a non existant listener.

Further investigation required.

comment:4 Changed 17 months ago by Stuart Auchterlonie

Resolution: Won't Fix
Status: newclosed

Closing any remaining tickets for 0.28, if the issue persists, feel free to reopen and align to v29 or master

Note: See TracTickets for help on using tickets.