Opened 2 years ago

Closed 2 years ago

#13036 closed Bug Report - General (Fixed)

mythtv-backend seems to be binding to 127.0.0.1, not address given

Reported by: brianary@… Owned by:
Priority: major Milestone: unknown
Component: MythTV - General Version: 0.28.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After the dist-upgrade switched my software sources from Mythbuntu to Ubuntu, I can only connect to my mythtv backend using a frontend on the same machine, but not a remote one. In the backend setup, I specified 192.168.1.189, the address of my server.

I've used this backend for many years. This only started after upgrading the software.

Running netstat -4lnp |grep :6543 returns:

tcp        0      0 127.0.0.1:6543          0.0.0.0:*               LISTEN      -

This makes me think the port is binding to the 127.0.0.1 address rather than the actual server address I've entered. Even though the local Myth frontend on the server points to the full server address, this could explain things, but I'm not sure how to fix it even if this were the case.

Change History (3)

comment:1 Changed 2 years ago by Peter Bennett

If you look at the backend log it lists all the ip addresses and ports it is listening on.

Is it possible that your ip address has changed or you entered the wrong one? If it is unable to listen on the specified ip address it defaults to 127.0.0.1. The same happens if the backend starts up before the network card is ready and the ip address is allocated. If your backend is started up at boot time this could be the problem.

comment:2 Changed 2 years ago by brianary@…

Good call! All I needed to do was restart the service! Thank you!

comment:3 Changed 2 years ago by Peter Bennett

Resolution: Fixed
Status: newclosed

This is fixed in MythTV 29, it by default listens on all IP addresses.

See #12498, #13024.

Note: See TracTickets for help on using tickets.