Opened 21 months ago

Closed 21 months ago

Last modified 21 months ago

#13073 closed Bug Report - General (Duplicate)

Detailed channel listing repeats title when it has multiple program ratings

Reported by: davos9554@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.28.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The query used in the detailed channel listing appears to repeat titles when there is more than 1 related programrating record.

It appears to be caused by this query from modules/tv/includes/programs.php

SELECT DISTINCT program.*,

UNIX_TIMESTAMP(program.starttime) AS starttime_unix, UNIX_TIMESTAMP(program.endtime) AS endtime_unix, IFNULL(programrating.system, "") AS rater, IFNULL(programrating.rating, "") AS rating, channel.callsign, channel.channum

FROM program USE INDEX (id_start_end)

LEFT JOIN programrating USING (chanid, starttime) LEFT JOIN channel USING (chanid) LEFT JOIN credits USING (chanid, starttime) LEFT JOIN people USING (person)

WHERE program.chanid=1698 AND program.starttime = '2017-07-22 08:00:00'

Attachments (4)

Capture1.PNG (28.3 KB) - added by davos9554@… 21 months ago.
Screen shot of channel listing
Capture2.PNG (162.9 KB) - added by davos9554@… 21 months ago.
Screenshot of SQL query result for specific time & channel
Capture3.PNG (75.3 KB) - added by davos9554@… 21 months ago.
Screen shot of program record for specific chan & time
Capture4.PNG (54.9 KB) - added by davos9554@… 21 months ago.
Screen shot of programrating records for specific chanid & starttime

Download all attachments as: .zip

Change History (7)

Changed 21 months ago by davos9554@…

Attachment: Capture1.PNG added

Screen shot of channel listing

Changed 21 months ago by davos9554@…

Attachment: Capture2.PNG added

Screenshot of SQL query result for specific time & channel

Changed 21 months ago by davos9554@…

Attachment: Capture3.PNG added

Screen shot of program record for specific chan & time

Changed 21 months ago by davos9554@…

Attachment: Capture4.PNG added

Screen shot of programrating records for specific chanid & starttime

comment:1 Changed 21 months ago by Gary Buhrmaster <gary.buhrmaster@…>

From appearances, you failed the ticket etiquette process, and failed to search for an existing ticket.

To an empowered trac admin: I would recommend this ticket be closed duplicate of 12822.

To the OP: Note that mythweb is deprecated, and unless someone is sufficiently motivated to provide a working patch, it as likely as not it will not be fixed before the code is eliminated. Does the same thing happen with the (new) internal myth frontend web server?

comment:2 Changed 21 months ago by sphery

Resolution: Duplicate
Status: newclosed

Dup of #12822

comment:3 Changed 21 months ago by davos9554@…

With respect, you do not know what was attempted. I am not as intimately involved in every one of the 300 open tickets the team has and I am not aware of every single bug that has ever existed in the code. As maybe someone intimately involved with this piece of the code you may be, but no one else is going to be, especially not a user. If you think searching for mythweb + duplicate or mythweb + repeat is going to return anything sensible then I hate to break this news to you, but it doesn't. If you don't care to hear about bug reports, then fine just mark the damn thing as closed or at least try to be respectful and tolerant of the fact that not every is aware of the bugs in the application. I am just trying to help you guys out, but I certainly won't try any further if this is the response I am going to receive.

BTW, within 15 seconds of using the webfrontend:

mythbackend[11846]: C CoreContext? signalhandling.cpp:305 (handleSignal) Received Segmentation fault: Code 1, PID -15, UID 7, Value 0x7fb64b29d53c

So obviously webfrontend is half-baked, I am glad that embedding a web server can crash the backend and abort my recordings.

Note: See TracTickets for help on using tickets.