Opened 14 years ago

Closed 14 years ago

#1318 closed defect (duplicate)

Ignore 'rerun' flag and 'original airdate' when program category == "News"

Reported by: briand Owned by: xris
Priority: minor Milestone: unknown
Component: mythweb Version: 0.19
Severity: low Keywords:
Cc: Ticket locked: no

Description

I *love* how mythweb now indicates which movies, specials, program episodes, etc I've previously recorded (even if they no longer exist in my /video directory)... but the side effect is that the local and national news are always shown has having been previously recorded. This is because the "original airdate" in the database is populated with a value usually more than 4 or 5 years ago (in one case, it's dated 1953!! [ABC World News Tonight]), for every instance of the program.

I would suggest that the 'rerun' flag and the 'original airdate' column in the program table be ignored when the 'category' == "News". That way, mythweb will not indicate that I've previously recorded next week's local 6:00pm newscast.

It might be trickier with 'category' == "Newsmagazine" -- they are often also shown with the 'rerun' flag and very old 'original airdate' [CBS 60 Minutes == '1968-09-24']... but some newsmagazine shows -are- indeed, repeats... a re-televising of a specific episode, or what-have-you.

I think my suggestion (above) will work for listings with 'category' == "News" ... but not sure we can ever get accurate results with 'category' == "Newsmagazine".

Change History (4)

comment:1 Changed 14 years ago by Isaac Richards

Component: mythwebmythtv
Resolution: invalid
Status: newclosed

Feature request without patch.

comment:2 Changed 14 years ago by Isaac Richards

Component: mythtvmythweb
Resolution: invalid
Status: closedreopened

Actually is a mythweb issue, not core as I thought.

comment:3 Changed 14 years ago by anonymous

Type: enhancementdefect

I get this also in mythweb 0.19. However it seems to happen for any "Title" that has been recorded previously. It seems to ignore the unique "Subtitle" and/or "Description". Working around this just for the news category is probably not sufficient. By the way this seems to be the same issue as http://svn.mythtv.org/trac/ticket/1334

This issue does not occur in mythfrontend.

comment:4 Changed 14 years ago by xris

Resolution: duplicate
Status: reopenedclosed

dupe of #1293, which is now closed.

Note: See TracTickets for help on using tickets.