Opened 23 months ago

Closed 22 months ago

Last modified 22 months ago

#13202 closed Bug Report - General (fixed)

playback doesn't start at begining

Reported by: w.newell@… Owned by: Roger Siddons
Priority: minor Milestone: 29.1
Component: MythTV - General Version: 0.28.1
Severity: low Keywords:
Cc: Ticket locked: no

Description

Recording set for 3 minutes early and commercial detection (set to start with recording). When you play it back, it starts 3 minutes into the recording, iow the normal start time for the recording instead of the actual recording start

Change History (15)

comment:1 Changed 23 months ago by Roger Siddons

Resolution: Invalid
Status: newclosed

That's intended behaviour.

See https://code.mythtv.org/trac/ticket/11713

There may be a Menu option "Play from beginning" to override it.

comment:2 Changed 23 months ago by w.newell@…

You know, if I didn't want to watch the show from the early time start period, I wouldn't set it to record early. Just freaking stupid imo.

comment:3 Changed 23 months ago by w.newell@…

BTW, The "Play from beginning" isn't a Menu option until after you've started the recording and then exit it. First time you go to the menu, the only option is Play. This is one one the dumbest changes I've seen. What's the logic behind this change in behavior?

comment:4 Changed 23 months ago by J.Pilk@…

If you want to start playback at the position identified by your commercial detector, add a call to 'mythutil --clearbookmarks' to the job.

This is an example of what I use in mythDVBcut.sh:

ionice -c3 mythutil --clearbookmarks --chanid 1002 --starttime 20180105205800 -q

See the last few comments in the Ticket referenced above.

comment:5 Changed 23 months ago by Roger Siddons

Most users want to watch programmes that start on or after the scheduled time, not the trailers/adverts/waffle that precede it.

The feature avoids the need to manually skip pre-roll for every viewing of every recording. The 'Start Early' pre-roll is usually considered as a safety buffer for those rare ocassions when programmes start early.

Eventually it may get hooked up to the actual programme start rather than the scheduled time. https://code.mythtv.org/trac/ticket/10101

With hindsight the feature should have been optional. However there's been a effort to avoid adding settings that no-one uses. Patches welcome.

Current workaround (I believe) is to hook the "mythutils --clearbookmarks" up to the "Recording Finished" System Event https://www.mythtv.org/wiki/MythTV_System_Events, which should "fix" completed recordings.

There's also a keybinding for JUMPSTART, which will take you back to file start, if you can spare a button on your remote.

comment:6 Changed 22 months ago by w.newell@…

It's not a rare occasion that programs start early here. It's a daily occurrence for at least one program that starts 2.5 minutes early every day. Adding a 3 minute start time to the recording rule used to take care of that. What you call a feature to me is an added inconvenience, but whatever. I've got a jump to beginning button on my remote.

comment:7 Changed 22 months ago by jpoet

I have one station which starts the first hour of "prime time" a minute early. The second hour starts 30 seconds early. The third hour is "on time". I believe they do it so they can squeeze in more commercials. Where I live (Mountain Time, USA) the local stations have to time-shift the content they receive from the major networks anyway, so they probably figure "why not?".

I have thought about tying this 'feature' to the "Recording Group", but have not had the time to implement that.

comment:8 in reply to:  5 Changed 22 months ago by gigem

Replying to rsiddons:

Most users want to watch programmes that start on or after the scheduled time, not the trailers/adverts/waffle that precede it.

I could probably buy that for pre-roll. I definitely can't for start-early. When I use start-early, it's because I have better knowledge than the guide data or what I want to record. I don't use it often, but everytime I do, I gnash my teeth when playback doesn't start where I expect/want it.

The 'Start Early' pre-roll is usually considered as a safety buffer for those rare ocassions when programmes start early.

Be careful with your terminology. Start early and pre-roll are very different things. Pre-roll is optional, opportunistic time added in seconds. Start early is mandatory time added in minutes explicitly requested by the user.

comment:9 Changed 22 months ago by Roger Siddons

Milestone: needs_triage29.1
Owner: set to Roger Siddons

comment:10 Changed 22 months ago by Roger Siddons

Resolution: Invalid
Status: closednew

comment:11 Changed 22 months ago by Roger Siddons <rsiddons@…>

Resolution: fixed
Status: newclosed

In 525132951ce61e1549cd64e6c4cf7946217de3b4/mythtv:

Allow 'Start playback from ProgStart?' to be disabled.

New setting in TV Settings/Playback? "UseProgStartMark?"
Defaults to disabled; user must opt-in to it.

New translatable string.

Fixes #13202

comment:12 Changed 22 months ago by Roger Siddons <rsiddons@…>

In b2aa2a73466ba288928713026c179d9c4143d415/mythtv:

Allow 'Start playback from ProgStart?' to be disabled.

New setting in TV Settings/Playback? "UseProgStartMark?"
Defaults to disabled; user must opt-in to it.

New translatable string.

Fixes #13202

(cherry picked from commit 525132951ce61e1549cd64e6c4cf7946217de3b4)

comment:13 Changed 22 months ago by w.newell@…

Thank you, thank you many times.

comment:14 Changed 22 months ago by J.Pilk@…

I've just spent an unexpectedly long time searching my menus for 'TV Settings' to get back the now-familiar Mythical-Bookmark behaviour.

I use MythCenter?-wide, with a few customisations, and it seems this doesn't have that option in the 'Default' mode. I expect I shall sort it out eventually, but as always things can be difficult at first.

http://lists.mythtv.org/pipermail/mythtv-users/2012-December/344515.html

comment:15 Changed 22 months ago by Roger Siddons

Apologies.

Default: Setup->Video->Playback->General Playback

Classic: Setup->TV Settings->Playback->General Playback

DVR: Utilities/Setup?->Setup->TV Settings->Playback->General Playback

MythCenter?: Advanced->Setup->TV Settings->Playback->General Playback

We need a "Search for setting" feature;)

Note: See TracTickets for help on using tickets.