Opened 22 months ago

Closed 22 months ago

Last modified 20 months ago

#13217 closed Bug Report - General (fixed)

mythpreviewgen crash

Reported by: dag@… Owned by: Peter Bennett
Priority: minor Milestone: 30.0
Component: MythTV - Mythpreviewgen Version: Master Head
Severity: high Keywords: crash
Cc: Ticket locked: no

Description

mythpreviewgen crashes for me in master.

The installation is one with a very long history of upgrades and it might well be a setting that is wrong. Bet there should still not be a crash :-)

Running under gdb gave me the crash line: #0 0x00007ffff4e5f6bd in AvFormatDecoder::H264PreProcessPkt(AVStream*, AVPacket*) (this=0x6eda90, stream=0x716e40, pkt=0x7fffa40037e0) at avformatdecoder.cpp:3465

The line is: if ((AVMEDIA_TYPE_VIDEO == enc->codec_type) &&

(kCodec_H264 == video_codec_id) && (enc->codec) && (enc->thread_count>1))

And sure enough enc returned from previous line is NULL. Perhaps a check and an error message?

Tell me what logs etc. you might need to sort this out!

Change History (7)

comment:1 Changed 22 months ago by dag@…

A bit more info:

This situation seems to appear when there is a DTV stream for AV_CODEC_ID_DVB_TELETEXT and I did not have that enabled in the compilation of the system.

ATM compiling with --enable-libzvbi

But again: Surely there shouldn't be a crash?

comment:2 Changed 22 months ago by Peter Bennett

Owner: changed from JYA to Peter Bennett
Status: newassigned

I think this is the same problem as your other ticket #13218. Is it the same file giving the problem?

comment:3 Changed 22 months ago by dag@…

That file was one of them and I also thought so first, but this was obviously on my selfcompiled backend and I had more possibilites of debugging. After the recompile with -libvzbi and a refreshed pull request it now seems to work though.

Still think there should be a test for null in the retrival of the decoder though :-)

comment:4 Changed 22 months ago by dag@…

Addition to previous note:

Actually just remembered that after the recompile with -libvzbi there wasn't a crash any more, but there wasn't any preview rendered either. The rendering process went into a loop and gave me similar messages as my Minimyth2 frond did.

It was finally checking out fixes/29 and installing that which solved theis problem.

comment:5 Changed 22 months ago by Peter Bennett <pbennett@…>

Resolution: fixed
Status: assignedclosed

In c9857a93f9bcfa2dfad39b0891f7f759a372504f/mythtv:

ffmpeg: Fix handling of stream changes and errors

If a stream cannot be decoded with hardware assist,
then try switching to software decoding.

If a stream cannot be software decoded, display an
error message to the user and stop playback.

Remove stream-change hacks for h264 that are no
longer necessary and are now causing a failure.

Fixes #13211
Fixes #13217
Fixes #13218
Fixes #13223

comment:6 Changed 21 months ago by Stuart Auchterlonie

Milestone: needs_triage30.0
Version: UnspecifiedMaster Head

comment:7 Changed 20 months ago by Peter Bennett

Owner: changed from Peter Bennett to Peter Bennett
Note: See TracTickets for help on using tickets.