Opened 14 years ago

Closed 14 years ago

#1325 closed defect (invalid)

XvMC segfault when exiting live-tv

Reported by: tralph11@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

SVN Revision: 8960

Watching live-tv and segfault occured on exit. Using XvMC and Chromakey OSD. Attaching gdb backtrace and mythfrontend log.

Attachments (2)

gdb_segsigv2.txt.gz (4.6 KB) - added by tralph11@… 14 years ago.
frontend_log2.txt.gz (20.9 KB) - added by tralph11@… 14 years ago.
mythfrontend logfile with prebuffering pause messages removed for smaller size

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by tralph11@…

Attachment: gdb_segsigv2.txt.gz added

Changed 14 years ago by tralph11@…

Attachment: frontend_log2.txt.gz added

mythfrontend logfile with prebuffering pause messages removed for smaller size

comment:1 Changed 14 years ago by danielk

Milestone: 0.20
Summary: mythfrontend segfault while exiting live-tvXvMC segfault whsn exiting live-tv

Please reproduce without chromakey osd enabled, and preferably with a memory checker (electric fence, valgrind, etc.)

It looks like the code where the crash happens is fine, but something bad happens earlier so that malloc/free doesn't work.

comment:2 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed
Summary: XvMC segfault whsn exiting live-tvXvMC segfault when exiting live-tv
Note: See TracTickets for help on using tickets.