Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#13281 closed Bug Report - General (Duplicate)

Setup - Edit Keys not reading modifiers correctly

Reported by: Steve Tremayne Owned by: Peter Bennett
Priority: minor Milestone: unknown
Component: MythTV - Mythtv-setup Version: v29.1
Severity: low Keywords: setup key
Cc: Ticket locked: no

Description

Whilst trying to add a symbol ("@") as a Jump Point, the actual key sequence that is stored is "Shift+@" - ie, I would need to press Shift twice

(I have a UK keyboard, where @=Shift+' a US keyboard would have @=Shift+2 )

So, in the database, this is stored as:

MariaDB [mythconverg]> select * from jumppoints where keylist like 'Shift%';
+-------------+-------------+---------+----------+
| destination | description | keylist | hostname |
+-------------+-------------+---------+----------+
| Play music  |             | Shift+@ | tower    |
+-------------+-------------+---------+----------+

Manually changing the DB, permits the correct key to be used:

MariaDB [mythconverg]> update jumppoints set keylist='@' where destination ='Play music' and hostname ='tower';
Query OK, 1 row affected (0.00 sec)
Rows matched: 1  Changed: 1  Warnings: 0

MariaDB [mythconverg]> select * from jumppoints where keylist like 'Shift%';
Empty set (0.00 sec)

This appears to be an issue in keygrabber.cpp at KeyGrabPopupBox::keyPressEvent() where key_name is set as a simple append of the modifier and the final key.

So, for my UK keyboard, this means I cannot use !"£$%, etc...

I'm not a QT developer, but I'd say the easiest solution here would be to only store the SHIFT modifier if the key pressed was an alphabetical one - this would then still permit ALT+2 (for example)

Currently, there's no way to use many of the symbol keys (without modifying the DB directly), so this limits the user selectable range of inputs.

Change History (2)

comment:1 Changed 17 months ago by Peter Bennett

Resolution: Duplicate
Status: newclosed

Duplicate of #13279 and #13280.

comment:2 Changed 17 months ago by Stuart Auchterlonie

Milestone: needs_triageunknown
Note: See TracTickets for help on using tickets.