Opened 18 months ago

Closed 14 months ago

Last modified 12 months ago

#13294 closed Bug Report - General (fixed)

mythfrontend playback of Music Choice channels constantly reset audio buffer

Reported by: liels Owned by: Peter Bennett
Priority: minor Milestone: 30.0
Component: MythTV - Video Playback Version: v29.1
Severity: medium Keywords: mythfrontend, playback, buffer, video, audio, Music Choice, SilliconDust
Cc: Ticket locked: no

Description

I'm able to record the Music Choice channels just fine, and they play great with VLC, mplayer and Kodi (including AC-3 passthrough), BUT, the mythfrontend continues to hickup on buffering and then resets the audio buffer leading to constant stutters (on different front ends, including very beefy workstations). The experience really renders the channels unusable through mythfrontend. I've updated my backend and frontend to v29.1-22-g675676b and it still doesn't work, and I can't seem to find any configuration changes that will make it work.

These suggest that it should work for 0.29 ... but it does not seem to ...

https://lists.gt.net/mythtv/users/606755?search_string=music%20choice;#606755

https://www.mythtv.org/wiki/Music_Choice

Attachments (1)

20181012_1730_musicchoice.patch (5.0 KB) - added by Peter Bennett 14 months ago.
Fixes problem of regular interruptions in music choice audio.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 18 months ago by Peter Bennett

Component: MythTV - GeneralMythTV - Video Playback
Owner: set to Peter Bennett
Status: newassigned
Version: Unspecifiedv29.1

comment:2 Changed 18 months ago by liels

The same or related problem exists in playback from other sources. I was watching the France vs Portugal World Cup match and gave up due to frequent audio dropouts. I tried watching the same file from the same frontend using VLC and the audio worked fine. If you like I can try to reproduce on different hardware. Regardless, it seems the audio buffer is resetting when it does not need to for many types of recordings (at least for ac3 passthrough). If it's helpful I can test on different hardware with different streams and see what happens. Anecdotally, this seems to be a problem on video recordings that might be captured not perfectly (Music Choice or not). Videos that come from pristine sources playback without audio (or other) problems (usually dts passthrough in my case.

comment:3 Changed 18 months ago by Peter Bennett

There is a new setting in the frontend setup->video->playback->general playback->audio read ahead, that I added last November to address certain cases of audio stuttering. This is only available in Master. If you are running Master you can try increasing that. This replaced the setting "Extra audio buffering" in earlier versions.

Changed 14 months ago by Peter Bennett

Fixes problem of regular interruptions in music choice audio.

comment:4 Changed 14 months ago by Peter Bennett

This patch is for music choice audio interruptions. There is a new setting (Enable Music Choice) with this patch that needs to be enabled for music choice to work smoothly.

This will not address audio dropouts when watching recorded video. If the "audio read ahead" setting in comment 3 does not fix that, open another ticket for that issue.

comment:5 Changed 14 months ago by Peter Bennett

Resolution: Fixed
Status: assignedclosed

commit aff9a8b5fda9616d6b8571cbed5db73af543b2d2 (HEAD -> master, origin/master) Author: Peter Bennett Date: Sun Oct 14 17:08:29 2018 -0400

TV Playback: Fix playback of Music Choice channels

Fix audio interruptions in playing music choice channels. There is a new setting to enable Music Choice. This needs to be selected for uninterrupted music choice playback. Whan this is enabled, there is a small chance that the code may misidentify regular video as music choice and that would cause lip sync problems. If that happens, Music choice should be disabled in settings.

Fixes #13294

comment:6 Changed 14 months ago by Peter Bennett <pbennett@…>

Resolution: Fixedfixed

In aff9a8b5f/mythtv:

TV Playback: Fix playback of Music Choice channels

Fix audio interruptions in playing music choice channels.
There is a new setting to enable Music Choice. This needs to be
selected for uninterrupted music choice playback. Whan this is enabled,
there is a small chance that the code may misidentify regular video as
music choice and that would cause lip sync problems. If that happens,
Music choice should be disabled in settings.

Fixes #13294

comment:7 Changed 14 months ago by Peter Bennett <pbennett@…>

In aff9a8b5f/mythtv:

TV Playback: Fix playback of Music Choice channels

Fix audio interruptions in playing music choice channels.
There is a new setting to enable Music Choice. This needs to be
selected for uninterrupted music choice playback. Whan this is enabled,
there is a small chance that the code may misidentify regular video as
music choice and that would cause lip sync problems. If that happens,
Music choice should be disabled in settings.

Fixes #13294

comment:8 Changed 12 months ago by Stuart Auchterlonie

Milestone: needs_triage30.0
Note: See TracTickets for help on using tickets.