Opened 14 months ago

Closed 9 months ago

Last modified 9 months ago

#13324 closed Bug Report - General (Duplicate)

count(): Parameter must be an array or an object that implements Countable!!

Reported by: zarthan Owned by: Stuart Auchterlonie
Priority: minor Milestone: 29.2
Component: MythTV - General Version: v29.1
Severity: low Keywords: Mythweb
Cc: Ticket locked: no

Description

This error shows up when creating a new schedule in Mythweb.

Warning at /usr/share/mythtv/bindings/php/MythBackend.php, line 194: !NoTrans: count(): Parameter must be an array or an object that implements Countable!!

From searching it may be related to PHP 7.2 I am running Xubuntu 18.04.1

Attachments (1)

version.txt (981 bytes) - added by zarthan 14 months ago.

Download all attachments as: .zip

Change History (6)

Changed 14 months ago by zarthan

Attachment: version.txt added

comment:1 Changed 14 months ago by zarthan

A post by daraden suggested a fix which I tried. It seems to make the error go away. https://forum.mythtv.org/viewtopic.php?p=13823#p13823

comment:2 Changed 14 months ago by jr3us

Note that this error in the title occurs elsewhere in the Mythweb code. An example below is:

Warning at /usr/share/mythtv/mythweb/modules/tv/tmpl/default/detail.php, line 845: !NoTrans: count(): Parameter must be an array or an object that implements Countable!!

I did a search through detail.php and there are 3 additional count references that could have the same above problem.

I will add this comment to the forum post as well.

comment:3 Changed 9 months ago by Stuart Auchterlonie

Resolution: Duplicate
Status: newclosed

Duplicate of #13406

comment:4 Changed 9 months ago by Stuart Auchterlonie

Milestone: needs_triage29.2

comment:5 Changed 9 months ago by Stuart Auchterlonie

Owner: set to Stuart Auchterlonie
Note: See TracTickets for help on using tickets.