Opened 14 months ago

Closed 12 months ago

Last modified 11 months ago

#13329 closed Patch - Feature (fixed)

Proposed patch - External recorder channel change can result in discontinuous changes for LiveTV

Reported by: Gary Buhrmaster Owned by: John Poet <jpoet@…>
Priority: minor Milestone: 30.0
Component: MythTV - Video Library Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

For your consideration:

During some testing of LiveTV with an external recorder (limited testing, I almost never use LiveTV) I encountered some non-reproducible issues with channel changes and video failures. I originally thought I had tracked them down to changes in video format between the channels, and applied the following patch, which seemed to help at least a few times.

Eventually I also made other changes to my external recorder to eliminate certain other channel change artifacts.

I have been unable to reproduce the original problem with or without this patch since I made those other changes to my external recorder. But this feels like it should be the correct value for the general case of external recorders and LiveTV.

diff --git a/mythtv/libs/libmythtv/cardutil.h b/mythtv/libs/libmythtv/cardutil.h
index b19c5b40ff..23f07bdd41 100644
--- a/mythtv/libs/libmythtv/cardutil.h
+++ b/mythtv/libs/libmythtv/cardutil.h
@@ -139,7 +139,8 @@ class MTV_PUBLIC CardUtil
 
     static bool         IsChannelChangeDiscontinuous(const QString &rawtype)
     {
-        return !IsEncoder(rawtype) || (rawtype == "HDPVR");
+        return !IsEncoder(rawtype) || (rawtype == "HDPVR") ||
+               (rawtype == "EXTERNAL");
     }
 
     static bool         IsUnscanable(const QString &rawtype)

Change History (3)

comment:1 Changed 12 months ago by jpoet

Resolution: Fixed
Status: newclosed

Fixed by 6cc3926e.

Thanks Gary.

comment:2 Changed 11 months ago by John Poet <jpoet@…>

Owner: set to John Poet <jpoet@…>
Resolution: Fixedfixed

In 6cc3926e09/mythtv:

Add EXTERNAL to list of types where CardUtil::IsChannelChangeDiscontinuous?.

Fixes #13329

comment:3 Changed 11 months ago by Stuart Auchterlonie

Milestone: needs_triage30.0
Note: See TracTickets for help on using tickets.