Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1333 closed defect (fixed)

Mythtranscode fails, "Unknown Socket Closing"

Reported by: gkruse@… Owned by: Geoffrey Hausheer
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: transcode Unkonwn socket
Cc: Ticket locked: no

Description

when mythtranscode is started from the frontend, it fails, command line works. See attached log for messages.

Attachments (1)

error.log (5.6 KB) - added by gkruse@… 14 years ago.
log

Download all attachments as: .zip

Change History (10)

Changed 14 years ago by gkruse@…

Attachment: error.log added

log

comment:1 Changed 14 years ago by gkruse@…

Keywords: ivtv bitrate added

Also note, the file it could not find does exist:

geoff@itchy:~$ file /var/lib/mythtv1009_20060218110000.mpg /var/lib/mythtv1009_20060218110000.mpg: MPEG sequence, v2, program multiplex

comment:2 Changed 14 years ago by gkruse@…

Keywords: transcode Unkonwn socket added; ivtv bitrate removed

I lied, I get the same error from the command line

comment:3 Changed 14 years ago by Geoffrey Hausheer

Owner: changed from Isaac Richards to Geoffrey Hausheer

It looks like you are using the mpeg2 transcoder. What is the command line you used? You will get this message if av_open_input_file fails to operate on the file. this implies that either (a) your stream is bad or (b) that there is a bug in libavformat.

The only way I'll be able to help you with this, is if you cut a couple megs from the beginning of the file and send it to me. Make sure that after cutting it, that it still fails for you. Send it to my e-mail: mythtv0368-at-phracturedblue-dot-com

comment:4 Changed 14 years ago by gkruse@…

I tried several different command lines as well as selecting to transcode from the frontend. Below are the commands, and I have e-mailed a few of the requested files to the address you posted.

Commands:

mythtranscode -l -i /var/lib/mythtv/1007_20060212210100.mpg -o /var/www/tv_transcoded/grey-for-shan.mpg -v all

mythtranscode -l --mpeg2 -c 1007 -s 2006-02-12-21:01:00 -o /var/www/tv_transcoded/grey-for-shan.mpg -v all

And about every other possible combination to transcode this file. This seems to be a problem with all of my files, not just this one. This used to work, but I can't remember the last time I used it successfully.

comment:5 Changed 14 years ago by Geoffrey Hausheer

Yes, I still need a copy of one of the streams that fails (probably baout 5MB off the front). It is the only way I can help you.

comment:6 Changed 14 years ago by anonymous

It looks like it's between svn 9015 to 9030. 9015 works. 9030 comes back with the error "Couldn't open input file, error #-2"

If you need any more info let me know, Bill

comment:7 Changed 14 years ago by Geoffrey Hausheer

Resolution: fixed
Status: newclosed

(In [9083]) A new define was missed when ffmpeg was resynced in #9024, causing mythtranscode to fail. This adds #define CONFIG_PROTOCOLS which closes #1333 A 'configure' and make clean is needed to see this update

comment:8 Changed 14 years ago by anonymous

I also see this same issue. I noticed this fix so I updated to the latest (At revision 9132) but I still see the same problem.

mythtranscode --mpeg2 --chanid 2260 --starttime 2006-02-19-15-45-00 2006-02-23 23:07:41.407 Using runtime prefix = /usr/local 2006-02-23 23:07:41.431 New DB connection, total: 1 2006-02-23 23:07:41.442 Enabled verbose msgs: important 2006-02-23 23:07:41.447 New DB connection, total: 2 2006-02-23 23:07:41.467 Couldn't open input file, error #-2

I end up with a zero byte file with some crazy user/group:

-rw-r--r-- 1 4294967294 4294967294 0 Feb 23 23:04 /mythfiles/recordings/2260_20060219154500.mpg.tmp

comment:9 Changed 14 years ago by anonymous

My bad. I pulled a clean SVN and rebuilt and it works fine. Sorry. Thanks for the fix!

Note: See TracTickets for help on using tickets.