Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#13348 closed Bug Report - General (fixed)

Setting a manual schedule not to record, wipes all program info.

Reported by: bib1963 Owned by: David Engel <dengel@…>
Priority: minor Milestone: 29.2
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I think this problem has been in mythtv for years, anyway...

Go into manual schedule and fill in some details, the details do not matter.

When you click next, you get taken to the page to decide whether to do not record, record only this showing etc.

Leave it at do not record and press next.

After a second or 2, the screen refreshes.

If you then go into the program guide, you will find every single program has been wiped from the schedules.

I have no idea which part of mythtv the problem is, but it is a huge one.

Change History (6)

comment:1 Changed 13 months ago by Jonatan Lindblad

Priority: criticalminor
Severity: highmedium

As described on https://code.mythtv.org/trac/wiki/TicketHowTo

Please do not increase a ticket's priority, severity, or milestone from the defaults. These fields are for the person who is fixing the issue to decide. Don't change these after the ticket's been filed, either - they'll likely just get changed back.

That said, I reproduced the issue and it was introduced in https://github.com/MythTV/mythtv/commit/526e89027ce152d2bffaa846cd3c1aff217c866d. I'm not familiar with this code but in this scenario m_recordID is 0 which is also the default value for program.manualid so all the guide data will be removed.

comment:2 Changed 13 months ago by David Engel <dengel@…>

Owner: set to David Engel <dengel@…>
Resolution: fixed
Status: newclosed

In a1349d7f5/mythtv:

Don't delete all programs when aborting a manual recording.

Fixes #13348

comment:3 Changed 13 months ago by David Engel <dengel@…>

In a1349d7f5/mythtv:

Don't delete all programs when aborting a manual recording.

Fixes #13348

comment:4 Changed 13 months ago by David Engel <dengel@…>

In 1f1081ccb0/mythtv:

Don't delete all programs when aborting a manual recording.

Fixes #13348

(cherry picked from commit a1349d7f535dfcc5993a1f515e4ee2cb257e3aa6)

comment:5 Changed 13 months ago by David Engel <dengel@…>

In 1f1081ccb0/mythtv:

Don't delete all programs when aborting a manual recording.

Fixes #13348

(cherry picked from commit a1349d7f535dfcc5993a1f515e4ee2cb257e3aa6)

comment:6 Changed 13 months ago by gigem

Milestone: needs_triage29.2
Note: See TracTickets for help on using tickets.