Opened 14 years ago

Closed 14 years ago

Last modified 10 months ago

#1336 closed defect (invalid)

Unknown column 'parentid' in 'where clause' (in capturecard)

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I updated to current svn. When i try to start mythbackend it tries to make this mysql:
SELECT cardid, hostname FROM capturecard WHERE parentid = '0' ORDER BY cardid

But because there is no "parentid" in "capturecard" mythbackend doesnt find any tv-cards.
ERROR:Unknown column 'parentid' in 'where clause'
After making a new column named "parentid" in "capturecard" everything works fine.

seemes that some Database-upgrade went wrong.

I dont think if this has something to do with it, but lately i patched this one: http://svn.mythtv.org/trac/attachment/ticket/1104/mythtv_ac3.17.patch

Change History (7)

comment:1 Changed 14 years ago by anonymous

Summary: no parentid = '0' in capturecardUnknown column 'parentid' in 'where clause' (in capturecard)

comment:2 Changed 14 years ago by Webmaaschter - a t - gmx.de

If you want to watch recordings this error occurs:
Unknown column 'transcoded' in 'field list'

Backend tries this: SELECT recorded.chanid,recorded.starttime,recorded.endtime,recorded.title,recorded.subtitle,recorded.description,recorded.hostname,channum,name,callsign,commflagged,cutlist,recorded.autoexpire,editing,bookmark,recorded.category,recorded.recgroup,record.dupin,record.dupmethod,record.recordid,outputfilters,recorded.seriesid,recorded.programid,recorded.filesize, recorded.lastmodified, recorded.findid, recorded.originalairdate, recorded.playgroup, recorded.basename, recorded.progstart, recorded.progend, recorded.stars, recordedprogram.stereo, recordedprogram.hdtv, recordedprogram.closecaptioned, transcoded FROM recorded LEFT JOIN record ON recorded.recordid = record.recordid LEFT JOIN channel ON recorded.chanid = channel.chanid LEFT JOIN recordedprogram ON (recorded.chanid = recordedprogram.chanid AND recorded.starttime = recordedprogram.starttime) WHERE (recorded.deletepending = 0 OR DATE_ADD(recorded.lastmodified, INTERVAL 5 MINUTE) <= NOW()) ORDER BY recorded

Again: adding column 'transcoded' results in working mythtv.

BTW: I just added 'transcoded' and 'parentid' as tinyint with standard=0 ...don't know if i can leave that like that.

comment:3 Changed 14 years ago by Robert Kulagowski

Do a make distclean and recompile. This will ensure that the next time you start the backend it will perform the schema update.

comment:4 Changed 14 years ago by webmaaschter - a t - gmx.de

Resolution: invalid
Status: newclosed

I always do a distclean.

But removing every patch and selfmade-changes helped.... curious.

Ok.. the problem is solved and i cannot reproduce it.

comment:5 Changed 10 months ago by Mark Kendall <mark.kendall@…>

In 5a0d0c0f9/mythtv:

Remove OpenGL1 support

comment:6 Changed 10 months ago by Mark Kendall <mark.kendall@…>

In 5a0d0c0f9/mythtv:

Remove OpenGL1 support

comment:7 Changed 10 months ago by Mark Kendall <mark.kendall@…>

In 5a0d0c0f9/mythtv:

Remove OpenGL1 support

Note: See TracTickets for help on using tickets.